Need help! - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-24-2017, 09:35 PM Thread Starter
Squid
 
Frerichs14's Avatar
 
Join Date: Jul 2017
Location: Nebraska
Posts: 5
Posting Frequency
 
Garage
Need help!

07 zx10r
Frerichs14 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-24-2017, 10:34 PM Thread Starter
Squid
 
Frerichs14's Avatar
 
Join Date: Jul 2017
Location: Nebraska
Posts: 5
Posting Frequency
 
Garage
07 ZX10R

i bought the bike a couple weeks ago first ninja when i was riding it home the battery got hot and lost power.

when i got it home and everything cooled down cause it was a very hot day that day i put in a new batt to see where i was at with the bike and do some tests

the stator was out>>> I mean out it was demagnitized!!! fell off in my hand it was replaced
rectifier was burnt out i replaced it
i also replaced the entire wiring harness just in case something broke in the harness and was grounded

i put everything back together along with a fresh oil change just because and as soon as i hook up the batt it pops the ECU fuse!! Please help i am ordering a new ecu for it tomorrow but any advise please
Frerichs14 is offline  
post #3 of 3 Old 01-28-2019, 08:41 AM
Track Day Rider
 
Join Date: Oct 2016
Posts: 182
Posting Frequency
 
Sounds like you need to take it to a professional

Sent from my SM-G930V using Tapatalk
bbsteinnewyork is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome