having problem with radiator - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-06-2010, 09:45 PM Thread Starter
Squid
 
sawhittingham's Avatar
 
Join Date: Apr 2010
Location: Columbus,Ga.
Posts: 6
Posting Frequency
 
having problem with radiator

my reserve tank keeps filling up but not put it back into radiator. what should i be looking for as a problem
sawhittingham is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-07-2010, 12:32 AM
Licensed Dist of HaterAde
 
TMY10ER's Avatar
 
Join Date: Sep 2009
Location: Houston,TX
Posts: 11,423
Posting Frequency
Images: 10
           
Send a message via Yahoo to TMY10ER
sounds like the thermostat is stuck/sticking, pull her out and check the spring? and to the forum bud!!!!!!!
TMY10ER is offline  
post #3 of 4 Old 05-08-2010, 01:34 PM Thread Starter
Squid
 
sawhittingham's Avatar
 
Join Date: Apr 2010
Location: Columbus,Ga.
Posts: 6
Posting Frequency
 
thank you ill try that
sawhittingham is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-08-2010, 01:37 PM Thread Starter
Squid
 
sawhittingham's Avatar
 
Join Date: Apr 2010
Location: Columbus,Ga.
Posts: 6
Posting Frequency
 
if any one can help me out i need a sevice manual for a zx-12.
sawhittingham is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Coolant/Radiator problem?! ikaika Performance and Tech 7 12-04-2009 05:23 PM
2008 zx10 Radiator problem mgroening Performance and Tech 13 07-30-2009 04:46 PM
radiator problem swolkreole The ZX-10R 1 04-22-2009 10:39 AM
FS: 06/07 ZX-10 Radiator dray4life Parts, Gear and Accessories 0 08-07-2007 10:19 PM
06 Radiator Different than 04/05 Radiator??? Vonstallin Performance and Tech 2 12-29-2006 01:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome