Hotbodies undertails - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 03-01-2006, 02:09 AM Thread Starter
 
Join Date: Feb 2006
Posts: 14
Posting Frequency
 
Hotbodies undertails

Can I get a quote on a Hotbodies undertail for a 05 Magma red?
luminescient is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 03-01-2006, 07:22 PM
GP Rider
 
TC24's Avatar
 
Join Date: Jan 2006
Location: Indianapolis, IN
Posts: 1,958
Posting Frequency
      
What ever you do, do not buy it. Took about four hours of work to get it to fit right, and paint doesn't match. Bought a couple things from them, always bad service and quality.
If you are going to buy it you will also need large clamps and epoxy to close up the gap, drill bits, and a turn signal delay.

'05 ZX-10R
'09 Streetglide
TC24 is offline  
post #3 of 10 Old 03-01-2006, 11:51 PM Thread Starter
 
Join Date: Feb 2006
Posts: 14
Posting Frequency
 
What would you recommend in place of it?
luminescient is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 03-01-2006, 11:57 PM
Street Rider
 
dmsrc's Avatar
 
Join Date: Aug 2005
Posts: 73
Posting Frequency
Images: 3
 
I just mounted mine and love it it took me about 1 hour and that included taking the tail off and putting it back together. No gaps. The paint color matches but it could have used a little more clear in it. On the bike it looks good. I'll try and post pics tomorrow, I'm at work right now. somebody on Ebay is selling an exact copy of it made of composite and no drilling for a real good price.

Dave
dmsrc is offline  
post #5 of 10 Old 03-02-2006, 09:06 AM
GP Rider
 
TC24's Avatar
 
Join Date: Jan 2006
Location: Indianapolis, IN
Posts: 1,958
Posting Frequency
      
^ look at where the undertail meets the brake light, the 3m tape is too thick, even the hotbodies display at the indy dealer expo had a gap.

do some searches of hotbodies on this site. 99% percent of them are complaints. from all the posts ive read it seems that rumble imports has a good product or also greggs.

'05 ZX-10R
'09 Streetglide
TC24 is offline  
post #6 of 10 Old 03-02-2006, 12:35 PM
Street Rider
 
dmsrc's Avatar
 
Join Date: Aug 2005
Posts: 73
Posting Frequency
Images: 3
 
Do a search on the site and you'll see different ways guy's are mounting it to get rid of the gapat the tail light.. Mine has absolutely no gap. I removed the tape and used silicone adhesive. Once again I will post pics. Hope this helps.

Dave
dmsrc is offline  
post #7 of 10 Old 03-02-2006, 05:58 PM
GP Rider
 
TC24's Avatar
 
Join Date: Jan 2006
Location: Indianapolis, IN
Posts: 1,958
Posting Frequency
      
when i bought mine i wasn't expecting to spend that much money and still have to change it to fit right. paint in still bad quality, looks like it was spray painted by a drunk.
you can look on there also i've replied to people how to get rid of the gap, mine has no gap now. i just feel that an undertail for a bike that practically already has one should should be better quality for the $200 price tag.

'05 ZX-10R
'09 Streetglide
TC24 is offline  
post #8 of 10 Old 03-02-2006, 06:05 PM
GP Rider
 
TC24's Avatar
 
Join Date: Jan 2006
Location: Indianapolis, IN
Posts: 1,958
Posting Frequency
      
i also purchased the front signals for my r6, the first set broke while i was finger tighening the nut. i called them and they said they would send a new set out if i sent the broken ones back. i wan't them on the bike so i purchased a second pair with the agreeance that i would be reimbursed for the first when they received the old ones, so i could get them quicker. two weeks passed by and i called them and they said that i didn't give the all of the credit card info, and they had not tried to contact me. finally got it squared away. not to mention every time i called they would say let me call back within the hour and never call back. so a few weeks later im at the bank and i discover that they've charged me for them again. still not solved said it would be next week for the refund of the now two sets.
not the kind of company i like to deal with, never even once apoligized.

'05 ZX-10R
'09 Streetglide
TC24 is offline  
post #9 of 10 Old 03-02-2006, 06:31 PM Thread Starter
 
Join Date: Feb 2006
Posts: 14
Posting Frequency
 
There was a gap on the one I got for my '04 R6, but I had heard that this was an anomoly on that year and model; interesting to hear that they have this problems on other bikes as well.
luminescient is offline  
post #10 of 10 Old 03-02-2006, 06:36 PM
GP Rider
 
TC24's Avatar
 
Join Date: Jan 2006
Location: Indianapolis, IN
Posts: 1,958
Posting Frequency
      
the '04 gixxers have a gap too, but i haven't really paid much attention to them on other bikes. i saw a new r1 with their exhaust/undertail, sounded worst than D&D, although i did't think that was possible. didn't get to get a good look at the r1 though, it was at night going down the road.

'05 ZX-10R
'09 Streetglide
TC24 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotbodies Race Bodywork...INSTAL HOW TO...With Pics!!! hillcountry10r The ZX-10R 52 02-20-2011 11:00 PM
Hotbodies Race Bodywork...INSTAL HOW TO...With Pics!!! hillcountry10r How To... 1 04-14-2005 04:54 PM
MRI - *NEW* Hotbodies Racing Undertails! (pics) [email protected] Vendors deals 9 01-29-2005 02:02 AM
ZX-10R Undertail Exhausts by Hotbodies Racing Punch The ZX-10R 32 07-01-2004 03:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome