Austin racing exhaust question - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-07-2019, 09:53 PM Thread Starter
Squid
 
Cagill's Avatar
 
Join Date: Aug 2018
Posts: 27
Posting Frequency
 
Austin racing exhaust question

Ordered my new Austin racing exhaust through Moto mummy they told me it would take 4 to 6 weeks because the exhaust is built after ordered or whatever. It's now been 8 weeks and no exhaust... When I ask/email motomummy they always say pretty much the same thing, basically it takes longer sometimes etc.. etc..... That's fine and I'm not freaking out at least not yet and I'm simply curious to know if anyone here has dealt with either vendor ? I'm sure alot of you have so what's your opinion of them? Thx for any reply in advance.
Cagill is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
ladwign
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen 4: Austin racing exhaust question Rcjohn9085 The ZX-10R 21 07-04-2016 10:29 PM
Gen 4: Austin Racing GP2R question tukn20s The ZX-10R 0 09-29-2013 06:50 PM
Gen 3: Austin Racing Question HZRDOS The ZX-10R 12 01-25-2013 05:41 PM
Gen 4: Austin Racing Exhaust / question casey.r.fitz The ZX-10R 28 07-26-2012 09:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome