turn signal troubles - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-04-2008, 11:31 AM Thread Starter
 
Join Date: May 2008
Posts: 4
Posting Frequency
 
turn signal troubles

i just bought me a 05 zx10r and none of the signals work it has power to the fuses and all the wires are hooked up but no power at the light i hooked the lights up directly to a hot wire and they work just wondering if this bike has a flasher like on cars and if so where is it thanks
poboy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-04-2008, 11:43 AM
 
Join Date: Apr 2007
Posts: 582
Posting Frequency
Images: 11
   
Hey welcome to the site POBOY and glad you're here, My bike is stored somewhere else right now :( otherwise Id go out and getcha a Definate answer but I can't now... Sorry but I do know there is a repair manual on here for the first generation try the search function for now... I have it downloaded too so I can email it to you in .pdf format if you want... Hope it helps
firerescue212 is offline  
post #3 of 6 Old 05-04-2008, 11:57 AM
GP Rider
 
JOSHUAZX10's Avatar
 
Join Date: Mar 2007
Location: Lakewood, CO
Posts: 1,134
Posting Frequency
Images: 7
   
Send a message via Yahoo to JOSHUAZX10
My 06 has a flasher under the seat next to the fuse box, I'm sure the 05 is relatively the same...
JOSHUAZX10 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-04-2008, 12:23 PM Thread Starter
 
Join Date: May 2008
Posts: 4
Posting Frequency
 
signals

do you no if it has a white plug with a orange an a brown wire i have one of those that is not plugged in to nothing
poboy is offline  
post #5 of 6 Old 05-04-2008, 12:30 PM
GP Rider
 
JOSHUAZX10's Avatar
 
Join Date: Mar 2007
Location: Lakewood, CO
Posts: 1,134
Posting Frequency
Images: 7
   
Send a message via Yahoo to JOSHUAZX10
just looked at my 06 and it's the same, an orange wire and a brown wire with a yellow stripe...problem solved
JOSHUAZX10 is offline  
post #6 of 6 Old 05-04-2008, 01:36 PM Thread Starter
 
Join Date: May 2008
Posts: 4
Posting Frequency
 
thanks that was a great help perfect
poboy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal fix for 08. Dino Pictures and Videos 21 04-28-2008 10:06 PM
WTB rt rear turn signal 06-07 & lft front turn signal zero lash Wanted: Buy or Trade 2 03-05-2008 08:33 AM
Turn signal mod? pieter3d The ZX-10R 27 12-03-2007 11:08 AM
Turn Signal? bcm0018 Performance and Tech 5 08-19-2007 11:55 AM
turn signal issue Supraman78 The ZX-10R 1 08-20-2006 10:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome