Techlusion DFO Installation help - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 04-21-2006, 10:44 PM Thread Starter
GP Rider
 
PatrickG's Avatar
 
Join Date: Dec 2005
Location: Elizabethtown, KY
Posts: 1,802
Posting Frequency
Images: 15
      
Techlusion DFO settings???????

I am having a Techlusion sent to me for free, but it came off a z1000 not a zx10r. So, the directions are going to be different. They are the same thing but will be hooked up different.
Kawasaki Z1000 2003-06 ZX10R 2004-05
FI-1020

Does anyone have their settings for the dials?

Last edited by PatrickG; 05-02-2006 at 08:35 PM.
PatrickG is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-22-2006, 03:11 AM
 
Join Date: Jun 2005
Posts: 477
Posting Frequency
 
Sell it and get a PC, do it right. Doesn't answer your question, but it's what I'd do.
Birdman is offline  
post #3 of 9 Old 04-23-2006, 10:29 PM
 
Join Date: Jan 2006
Posts: 186
Posting Frequency
 
got 1 for my r1 and it only richens the mixture,not what I needed on the dyno. easy to install though.
hsmarc is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 05-02-2006, 02:55 PM Thread Starter
GP Rider
 
PatrickG's Avatar
 
Join Date: Dec 2005
Location: Elizabethtown, KY
Posts: 1,802
Posting Frequency
Images: 15
      
I have installed mine and it was very easy to figure out.

I know that no one wants to admit having one of these TFI's. But if you do, you can "secretly" send me a PM with you dial/pot settings. To guide me in the right direction.

I won't tell anyone......
PatrickG is offline  
post #5 of 9 Old 05-02-2006, 09:04 PM
 
Join Date: Jun 2005
Posts: 477
Posting Frequency
 
Hahahaha Funny, but what if the right direction is to (and it will be in many parts of the map) remove fuel. What then?
Birdman is offline  
post #6 of 9 Old 07-23-2006, 09:00 AM
Street Rider
 
Join Date: Jun 2006
Location: Tampa Bay Florida
Posts: 80
Posting Frequency
 
Quote:
Originally Posted by PatrickG
I have installed mine and it was very easy to figure out.

I know that no one wants to admit having one of these TFI's. But if you do, you can "secretly" send me a PM with you dial/pot settings. To guide me in the right direction.

I won't tell anyone......
Patrick,

Did you install the Techlusion on your Ten?

What were the results? Any conclusions?

Dave
Dave Bogue is offline  
post #7 of 9 Old 07-23-2006, 01:12 PM Thread Starter
GP Rider
 
PatrickG's Avatar
 
Join Date: Dec 2005
Location: Elizabethtown, KY
Posts: 1,802
Posting Frequency
Images: 15
      
Quote:
Originally Posted by Dave Bogue
Patrick,
Did you install the Techlusion on your Ten?
What were the results? Any conclusions?
Dave
Dave,
Sure did!! I don't have it perfect, but it did take most of the ON/OFF abruptness feel from the throttle. And it pulls hard from 4,000 now instead of 6,000 rpms. I am pretty happy with it, but of course I got it for a steal. I haven't put it on the dyno with air/fuel sniffer yet. So, I can't tell you where it is running rich or lean. But overall I am satisified with the mod, I really wasn't looking for lots more HP, just smoother throttle control and maybe fill in the gaps in the fuel/air mixture.
PatrickG is offline  
post #8 of 9 Old 07-23-2006, 03:03 PM
Street Rider
 
Join Date: Jun 2006
Location: Tampa Bay Florida
Posts: 80
Posting Frequency
 
Sounds good!

Did you dial it in using "trial and error" or did you get some recommendations from www.Techlusion.com?

I have a stock 2006 (lowered and geared) that pulls very hard from the midrange, but I think is lean on the bottom half of the rpm range. Did you add fuel down low?

Best wishes,
Dave
Dave Bogue is offline  
post #9 of 9 Old 07-23-2006, 05:55 PM Thread Starter
GP Rider
 
PatrickG's Avatar
 
Join Date: Dec 2005
Location: Elizabethtown, KY
Posts: 1,802
Posting Frequency
Images: 15
      
Quote:
Originally Posted by Dave Bogue
Sounds good!

Did you dial it in using "trial and error" or did you get some recommendations from www.Techlusion.com?

I have a stock 2006 (lowered and geared) that pulls very hard from the midrange, but I think is lean on the bottom half of the rpm range. Did you add fuel down low?

Best wishes,
Dave
I have on 05' and I left it almost exactly the way they said to set it up on their website. I think I added a little more in the midrange but that was it, just because of the Yoshi pipe.
PatrickG is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch installation with pictures. Vonstallin Performance and Tech 97 11-15-2015 05:44 PM
"How to" Power commander installation...lot of pictures lespaul66 Performance and Tech 3 03-12-2006 03:17 PM
"How to" Power commander installation...lot of pictures lespaul66 How To... 0 03-12-2006 08:32 AM
Frame Slider Installation racerman Performance and Tech 16 05-10-2005 08:01 PM
TRE installation help..... Ground Zero Performance and Tech 15 10-05-2004 05:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome