Speedo Healer for Gen 4 ZX10r? - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 Old 06-05-2011, 12:30 AM Thread Starter
Champion Rider
 
speedy14's Avatar
 
Join Date: May 2011
Location: Northeast Austin
Posts: 356
Posting Frequency
 
Speedo Healer for Gen 4 ZX10r?

I ordered the Speedohealer and then was told that it will not work on the 2011 bike because of the Traction Control system? :headshake
Has anyone found a speedo correction device that will work on the new ZX10R?
speedy14 is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 06-05-2011, 12:36 AM
Street Rider
 
Sgt Amazing's Avatar
 
Join Date: Feb 2011
Location: San Diego
Posts: 69
Posting Frequency
 
I thought that there is no need b/c the speed is not read from the crank, its read from the rings on the rims
Sgt Amazing is offline  
post #3 of 24 Old 06-05-2011, 02:04 AM
WSB Rider
 
Flipr's Avatar
 
Join Date: Dec 2009
Location: Melbourne,Australia
Posts: 825
Posting Frequency
Images: 3
  
Quote:
Originally Posted by Sgt Amazing View Post
I thought that there is no need b/c the speed is not read from the crank, its read from the rings on the rims
Speed sensors on wheels means you can change your gearing,etc so there is no need for a correction device.

Area P slip-on & link pipe,De-catted Headers,PCV & Autotune,Ivans block off plates,K & N filter,X-Tre,Driven Superlite sprockets,+2 rear,stock front,520 conversion,V4 Speedohealer,Servo motor eliminator,Re-valved Ohlins damper,Spiegler front brake lines,Zero Gravity SR dark smoke screen,Stompgrip tank pads,ZX-6 rear cowl,and more to come.

Speed dosen't kill,it's the sudden stop!!!
Flipr is offline  
Sponsored Links
Advertisement
 
post #4 of 24 Old 06-05-2011, 02:42 AM
GP Rider
 
The Nam3less's Avatar
 
Join Date: Nov 2010
Location: Mesa, Az
Posts: 1,755
Posting Frequency
           
Quote:
Originally Posted by sgt amazing View Post
i thought that there is no need b/c the speed is not read from the crank, its read from the rings on the rims



'11 Black zx-10r | Tech-spec Tank pad | Akraprovic w/ link | Power Commander V | Auto tune | HID | 1/5 Insert | Driven Smog Plates | DMP integrated tail light | Vortex rear sets w/ new pressure switch | Puig dark smoke windscreen | BMC Air Filter | Cox Radiator Guard |

To Do List:
ECU reflash
Steering Damper revalved
The Nam3less is offline  
post #5 of 24 Old 06-05-2011, 03:48 AM
Bloo Moderator
 
bluedevil's Avatar
 
Join Date: Nov 2004
Location: SAC,CA
Posts: 23,742
Posting Frequency
Images: 3
           
Here is a thought though....we all know all Clusters are about 6% error so it wouldn't matter if the 4th Gen is read from the wheels...the cluster is still in play and maybe in need of SpeedoHealer if you want to be exact.

We will need more info. on the cluster to see if there is a big error....if there is then yes it may need one but that may be decided on what kind of signal the cluster needs to convert if not the same as a conventional speed sensor device.

bloo
bluedevil is offline  
post #6 of 24 Old 06-05-2011, 04:34 AM
GP Rider
 
The Nam3less's Avatar
 
Join Date: Nov 2010
Location: Mesa, Az
Posts: 1,755
Posting Frequency
           
Quote:
Originally Posted by bluedevil View Post
Here is a thought though....we all know all Clusters are about 6% error so it wouldn't matter if the 4th Gen is read from the wheels...the cluster is still in play and maybe in need of SpeedoHealer if you want to be exact.

We will need more info. on the cluster to see if there is a big error....if there is then yes it may need one but that may be decided on what kind of signal the cluster needs to convert if not the same as a conventional speed sensor device.

bloo
are you sure it is about 6% with the new system on the gen 4 though?

I get what you mean on this but it seems to be a bit pointless with just having a minor adjustment. most drag racers look at rpm not speed (track will tell you the speed on your ticket).... most track days people look at what gear they are in not speed. Most people doing top speed runs use GPS anyways. Most street riders are not doing over 120 mph ..... so at 6% of 120 mph you are 7mph off (big wow there). so why fix a small percentage that you might have with a gen 4? just an on your bloo



'11 Black zx-10r | Tech-spec Tank pad | Akraprovic w/ link | Power Commander V | Auto tune | HID | 1/5 Insert | Driven Smog Plates | DMP integrated tail light | Vortex rear sets w/ new pressure switch | Puig dark smoke windscreen | BMC Air Filter | Cox Radiator Guard |

To Do List:
ECU reflash
Steering Damper revalved
The Nam3less is offline  
post #7 of 24 Old 06-05-2011, 10:08 AM
Speed Freak
 
garth285's Avatar
 
Join Date: Apr 2006
Location: PSL, Florida
Posts: 12,730
Posting Frequency
           
Send a message via AIM to garth285
Yesh thats correct you cannot run a speedo healer on these systems....

You might be able to make it work from the ECU to the speedometer though possibly if you knew how much the factory cluster is off....

I can tell you that the 2011's speedometer is slightly off, I dont knwo the % but its minimal, not enough to get you in trouble with the law (unless your breaking it already)
garth285 is offline  
post #8 of 24 Old 06-05-2011, 07:05 PM
Bloo Moderator
 
bluedevil's Avatar
 
Join Date: Nov 2004
Location: SAC,CA
Posts: 23,742
Posting Frequency
Images: 3
           
Quote:
Originally Posted by bluedevil View Post
Here is a thought though....we all know all Clusters are about 6% error so it wouldn't matter if the 4th Gen is read from the wheels...the cluster is still in play and maybe in need of SpeedoHealer if you want to be exact.

We will need more info. on the cluster to see if there is a big error....if there is then yes it may need one but that may be decided on what kind of signal the cluster needs to convert if not the same as a conventional speed sensor device.

bloo
Quote:
Originally Posted by The Nam3less View Post
are you sure it is about 6% with the new system on the gen 4 though?

I get what you mean on this but it seems to be a bit pointless with just having a minor adjustment. most drag racers look at rpm not speed (track will tell you the speed on your ticket).... most track days people look at what gear they are in not speed. Most people doing top speed runs use GPS anyways. Most street riders are not doing over 120 mph ..... so at 6% of 120 mph you are 7mph off (big wow there). so why fix a small percentage that you might have with a gen 4? just an on your bloo
No I am not sure of the error and that's why I said we need more info. If you do searches on this site or go to Speedhealers website you will see there is a DEMAND to have by owners Clusters EXACT, not about racing at all and they seem to be doing good in that market for that alone.

Quote:
Originally Posted by garth285 View Post
Yesh thats correct you cannot run a speedo healer on these systems....

You might be able to make it work from the ECU to the speedometer though possibly if you knew how much the factory cluster is off....

I can tell you that the 2011's speedometer is slightly off, I dont knwo the % but its minimal, not enough to get you in trouble with the law (unless your breaking it already)
I guess over time...check that I know over time the EXACT or GENERAL percentage error will be posted on this site for this New Gen 4 Cluster and how to fix it if need be.....again as I said above or to make it clearer....what 1 Rider calls good enough or not important for error is not the same or good enough for other street riders or racers.......I would need to see the Gen 4 manual to see if it's possible with a speedohealer or compatible with the signals the Gen 4 ECU is sending for speed.

bloo
bluedevil is offline  
post #9 of 24 Old 06-05-2011, 07:37 PM
WSB Rider
 
jstilly85's Avatar
 
Join Date: Apr 2011
Location: Indiana
Posts: 585
Posting Frequency
 
Quote:
Originally Posted by garth285 View Post
Yesh thats correct you cannot run a speedo healer on these systems....

You might be able to make it work from the ECU to the speedometer though possibly if you knew how much the factory cluster is off....

I can tell you that the 2011's speedometer is slightly off, I dont knwo the % but its minimal, not enough to get you in trouble with the law (unless your breaking it already)
I dunno, My GEN 4 seems to be way off. I run down the highway doing 87MPH. I KNOW these cats in my area arent doing but 73 at the most, and i'm falling behind. For whatever reason, I think im +/- 10% or more. I dont understand why bike manufactures can't get this right, seems pretty simple. I dont know if there is a reason or not.

Bikes
2007 Kawasaki ZZR600 (Sold)
2009 Yamaha R6 (Sold)
2011 Kawasaki ZX10R (Sold)
2005 Yamaha R1 (Sold)
2011 Kawasaki ZX10R (Sold)
2015 Kawasaki ZX10R

[MODS: Two Bros M2 Shorty : Shogun Frame Sliders : Techspec Tank Grip : K&N Race Air Filter : Shorty Levers : Custom R6 Plate Bracket
jstilly85 is offline  
post #10 of 24 Old 06-05-2011, 07:49 PM
Bloo Moderator
 
bluedevil's Avatar
 
Join Date: Nov 2004
Location: SAC,CA
Posts: 23,742
Posting Frequency
Images: 3
           
Quote:
Originally Posted by jstilly85 View Post
I dunno, My GEN 4 seems to be way off. I run down the highway doing 87MPH. I KNOW these cats in my area arent doing but 73 at the most, and i'm falling behind. For whatever reason, I think im +/- 10% or more. I dont understand why bike manufactures can't get this right, seems pretty simple. I dont know if there is a reason or not.
Well here we go, sounds like just any other cluster error reported for any gen. ...now the fix for this bike lets get er done.
bluedevil is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
FS NIB Speedo Healer + Harness for 06-10 ZX10R $75 Shipped wickedsprint Parts, Gear and Accessories 2 12-20-2010 10:33 PM
Speedo Healer for 05 ZX10R TR-10 Parts, Gear and Accessories 5 06-12-2007 11:41 PM
Speedo healer settings 06 zx10r Strawman1368 Performance and Tech 2 02-26-2007 11:42 AM
06 ZX10R Speedo Healer, anybody fitted one? (advice needed) edgey999 Performance and Tech 10 05-19-2006 06:33 PM
F/S Speedo Healer 04/05 ZX10R dr_wookiee Parts, Gear and Accessories 6 03-12-2006 08:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome