Popping On Decel/Shooting Flames - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 32 Old 05-11-2007, 11:13 AM Thread Starter
Street Rider
 
Join Date: Nov 2006
Location: Saskatoon, Sask CANADA
Posts: 56
Posting Frequency
 
Send a message via MSN to CurtZX
Popping On Decel/Shooting Flames

Hello Folks,

Quick question here. I have had my 05 10R for about a year, ~15,000kms on the bike. It has a K&N Filter and a Leo Vince Highmount Exhaust Slip On(nothing really 'performance' wise other than that) No PCIII or anything...yet.

Here is my question!

Since I took it out of storage this spring it has been popping/backfiring hard on deceleration and (as per my friend last night) apparentely shooting blue flames.

Now, I am going to assume it is building up fuel on decel and that would explain the whole deal, but my question is: What do you guys suggest I do to remedy the problem? I wasnt really 'planning' on buying a PCIII this year..But I suppose if push comes to shove I will suck it up.

Thanks a lot for your help guys

Curt
Saskatoon, Saskatchewan
CurtZX is offline  
Sponsored Links
Advertisement
 
post #2 of 32 Old 05-11-2007, 11:22 AM
WSB Rider
 
missinlinc's Avatar
 
Join Date: Dec 2006
Location: Georgia is home, but the Army has me in San Antonio, TX!!!
Posts: 880
Posting Frequency
Images: 7
  
I think the flames would look cool as hell!!! Hmmm wonder how I can get mine to do that???

missinlinc is offline  
post #3 of 32 Old 05-11-2007, 12:06 PM
Champion Rider
 
brianhevans's Avatar
 
Join Date: Oct 2005
Location: Irvine, CA
Posts: 344
Posting Frequency
Images: 17
 
Send a message via MSN to brianhevans
It's ok, don't worry about that. Mine does this as well.
brianhevans is offline  
Sponsored Links
Advertisement
 
post #4 of 32 Old 05-11-2007, 12:17 PM
WSB Rider
 
drkramm's Avatar
 
Join Date: Nov 2006
Location: catasauqua, pa
Posts: 798
Posting Frequency
  
you can try and remove the kleen system from it that helps a lil on the pop best bet is a power commander but like stated before on here its not really bad

"Once you've tasted flight, you will forever walk the earth with your eyes turned skyward, for there you have been and there you long to return."
drkramm is offline  
post #5 of 32 Old 05-11-2007, 12:29 PM
Hillbillie Mod
 
hillcountry10r's Avatar
 
Join Date: Jun 2004
Location: TEXAS
Posts: 20,155
Posting Frequency
Images: 31
           
Send a message via Yahoo to hillcountry10r
keep it above 8K and it wont do that.




For every species of beasts and birds, of reptiles and creatures of the sea, is tamed and has been tamed by the human race. But no one can tame the tongue; it is a restless evil full of deadly poison.
James 3:7,8

hillcountry10r is offline  
post #6 of 32 Old 05-11-2007, 12:33 PM Thread Starter
Street Rider
 
Join Date: Nov 2006
Location: Saskatoon, Sask CANADA
Posts: 56
Posting Frequency
 
Send a message via MSN to CurtZX
Good stuff! My old TLR liked to do it as well.. To be honest, I think it is kind of cool, and by experience its not hard on an engine, but just thought I would check before I dug into her! - Thanks boys

Curt
Saskatoon, Saskatchewan
CurtZX is offline  
post #7 of 32 Old 05-11-2007, 12:49 PM
Champion Rider
 
GreenGoblin's Avatar
 
Join Date: Apr 2006
Location: Jacksonville, North Carolina
Posts: 334
Posting Frequency
 
I have a PCIII and Akra full system and mine does it, too. I was wondering the same thing.
GreenGoblin is offline  
post #8 of 32 Old 05-11-2007, 12:52 PM
Retired post whore
 
Alien10's Avatar
 
Join Date: Apr 2007
Location: New Jersey
Posts: 8,463
Posting Frequency
Images: 10
           
My 04 does it too - all my friends tell me it looks cool at night time. Have a power commander for this season maybe that will clean it up.

"All that is necessary for the triumph of evil is that good men do nothing." - Edmond Burke (1729-1797)
Alien10 is offline  
post #9 of 32 Old 05-11-2007, 01:12 PM
GP Star
 
Join Date: Nov 2005
Posts: 2,477
Posting Frequency
        
Well I had my PC3 tuned today, the tuner removed a hose from under the airbox and blocked it. He told me that's for emissions and it is causing the backfiring (popping sound). After the dyno I still noticed backfiring but not as much as before.
Hattori Hanzo is offline  
post #10 of 32 Old 05-11-2007, 03:43 PM
GP Star
 
05ZixxR's Avatar
 
Join Date: Aug 2005
Location: providence RI
Posts: 2,049
Posting Frequency
Images: 2
  
Send a message via AIM to 05ZixxR
i love every noise my bike makes...i love my bike

full ahead hard and fast....
05ZixxR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Flames, do it yourself or pay? sinister_psycho The Out House 7 11-12-2006 11:30 AM
Decel pop with M4 slip on sneaky Performance and Tech 6 11-16-2005 10:26 AM
Popping on decel FiX! DustinR Performance and Tech 16 04-06-2005 04:37 AM
Backfiring Exhaust on Decel DB's ZX10R The ZX-10R 3 11-23-2004 10:45 AM
Got Flames??? Vonstallin The ZX-10R 10 07-11-2004 02:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome