Oil seepage??? - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 05-24-2007, 12:21 AM Thread Starter
Champion Rider
 
majin ssj eric's Avatar
 
Join Date: Mar 2007
Location: Saint Simons Island, GA
Posts: 413
Posting Frequency
Images: 11
 
Send a message via AIM to majin ssj eric
Oil seepage???

Every time I come back from a ride I've noticed that there is a thin film of oil on the clutch cover obviously seeping down from the filler cap. The oil seeps down the cover and onto the back of my lower fairing. I clean it off everytime, but it always comes back on my next ride. The amount of oil is very small but it is still there. Has anybody else noticed this? At first I thought that I had overfilled on my last oil change, but I just changed the oil last week with the exact correct amount and its still doing it. Anyway, I'm not really worried about it but it is kind of annoying to have to keep wiping it off. It's an '06 btw...

majin ssj eric is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 05-24-2007, 08:03 AM
Champion Rider
 
CountDokoo's Avatar
 
Join Date: May 2004
Location: Singapore
Posts: 270
Posting Frequency
Images: 1
 
did you recently remove and reinstall your clutch cover? if so you might have to put some gasket sealant in between the cover and the case
CountDokoo is offline  
post #3 of 11 Old 05-24-2007, 08:06 AM
Yankee Racer
 
zx10ragentblack's Avatar
 
Join Date: Aug 2004
Location: Indianapolis
Posts: 14,838
Posting Frequency
Images: 9
           
Send a message via Yahoo to zx10ragentblack
I would clean off the cap good and also think about buying a new cap or at least a new ring for the cap. I had the same thing happen and I just cleaned off the seal on the cap real good and it was fine. I also found out that I was putting to much oil in my bike and that was part of the issue as well.
zx10ragentblack is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 05-24-2007, 08:07 AM
Yankee Racer
 
zx10ragentblack's Avatar
 
Join Date: Aug 2004
Location: Indianapolis
Posts: 14,838
Posting Frequency
Images: 9
           
Send a message via Yahoo to zx10ragentblack
Moved here

JJ
zx10ragentblack is offline  
post #5 of 11 Old 05-24-2007, 08:37 AM
FAF
Rent this space
 
Join Date: Feb 2006
Location: Pennsylvania
Posts: 6,590
Posting Frequency
Images: 8
           
I presume the O ring is still on the cap ??
FAF is offline  
post #6 of 11 Old 05-24-2007, 11:06 AM Thread Starter
Champion Rider
 
majin ssj eric's Avatar
 
Join Date: Mar 2007
Location: Saint Simons Island, GA
Posts: 413
Posting Frequency
Images: 11
 
Send a message via AIM to majin ssj eric
Quote:
Originally Posted by FAF View Post
I presume the O ring is still on the cap ??
You presume wrong and I'm a friggin retard! I found an O-ring in the pan I drained the oil in but couldn't figure out what it came from. Now that you mentioned an O-ring for the cap I went out to the garage and fitted my "mystery-ring" to the cap and voila. I feel like a real douche. Thanks guys!

majin ssj eric is offline  
post #7 of 11 Old 05-24-2007, 11:11 AM
Yankee Racer
 
zx10ragentblack's Avatar
 
Join Date: Aug 2004
Location: Indianapolis
Posts: 14,838
Posting Frequency
Images: 9
           
Send a message via Yahoo to zx10ragentblack
Quote:
Originally Posted by majin ssj eric View Post
You presume wrong and I'm a friggin retard! I found an O-ring in the pan I drained the oil in but couldn't figure out what it came from. Now that you mentioned an O-ring for the cap I went out to the garage and fitted my "mystery-ring" to the cap and voila. I feel like a real douche. Thanks guys!
glad it was such a simple fix.
zx10ragentblack is offline  
post #8 of 11 Old 05-24-2007, 02:00 PM
I really need to get out of the house
 
Big Daddy's Avatar
 
Join Date: Dec 2003
Posts: 34,537
Posting Frequency
Images: 38
           
Quote:
Originally Posted by majin ssj eric View Post
You presume wrong and I'm a friggin retard! I found an O-ring in the pan I drained the oil in but couldn't figure out what it came from. Now that you mentioned an O-ring for the cap I went out to the garage and fitted my "mystery-ring" to the cap and voila. I feel like a real douche. Thanks guys!

pardon me but would you kindly place the keys in your mail box and send me your address so that i may stop by and take your toy away for 30 days.

BD




Those who stir the shit pot should have to lick the spoon.
Big Daddy is offline  
post #9 of 11 Old 05-24-2007, 02:03 PM
Yankee Racer
 
zx10ragentblack's Avatar
 
Join Date: Aug 2004
Location: Indianapolis
Posts: 14,838
Posting Frequency
Images: 9
           
Send a message via Yahoo to zx10ragentblack
Quote:
Originally Posted by Big Daddy View Post
pardon me but would you kindly place the keys in your mail box and send me your address so that i may stop by and take your toy away for 30 days.

BD
I'm closer BD, I'll "hold" it for him.
zx10ragentblack is offline  
post #10 of 11 Old 05-24-2007, 03:44 PM
GP Rider
 
Rspec99's Avatar
 
Join Date: May 2004
Location: Great White North
Posts: 1,634
Posting Frequency
Images: 11
      
Cool.. now you know why they call it an "Oh-ring" ;)

I had the same thing happen to me after an oil change. It dribbled a bit but went away after I cleaned it up. Seems to be common after an oil change on the ZX10.
Rspec99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
oil seepage @ filter base Big Daddy Performance and Tech 34 05-31-2007 11:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome