Gen 1: 2004-2005 Major fuel eco issues - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-30-2019, 04:48 AM Thread Starter
Squid
 
Join Date: Jan 2019
Posts: 8
Posting Frequency
 
Major fuel eco issues

I have the 05 ZX10R and I don't know why but recently I've been getting stupid bad gas mileage, I can fill up and around 80 miles my gas light coming on, I've even had my gas light on put around $8 in there and around the 45 mile mark my gas light is on once again. I know I'm not the only one that goes over the speed limit but this is not even riding full throttle wide open. This is just a steady Cruise around between 6 and 8,000 RPMs and when I really decide to open it up of course it's even worse... SO PLZ ANY INFO WOULD BE GREATLY APPRECIATED
Justin Williams is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-30-2019, 05:09 AM
GP Rider
 
michael4012's Avatar
 
Join Date: Dec 2014
Location: England
Posts: 1,188
Posting Frequency
 
Has suddenly started happening or has it been gradually getting worse, have you done any work on the bike that could have disturbed anything. Gearing have you altered the final drive?
michael4012 is offline  
post #3 of 4 Old 05-01-2019, 06:31 AM
WSB Rider
 
badassjake's Avatar
 
Join Date: Jun 2010
Location: Atlantic CANADA
Posts: 939
Posting Frequency
 
last spark plug change?

air filter new?(over oiled) , bad dirty air filter ?

2004 ZX10R-few mods here and there......
and even made more Evil by Woolich.
badassjake is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-14-2019, 11:29 PM Thread Starter
Squid
 
Join Date: Jan 2019
Posts: 8
Posting Frequency
 
Not sure how gradually but almost seemed to have caught me off gaurd once i realized it and i havent done anything on the bike since i got it other than oil change & recently removed tolhe power comander to see if it would make a diff. But unfortunately not, I bought the plugs to change them, I'm doing so here shortly I was looking online first to see if they could be the issue because someone else had mentioned it as well as the air filter and whatnot which I went ahead in checked cleaned and all that. Still no difference and then when I Googled the effects that's part supposed to have the only thing that seemed 3 second place was settings gas mileage but it didn't seem to have any of the other symptoms plugs have been known to cause. I had one friend told me that it might be the valves that is it was the valves it was drink up a lot of gas oh, don't know if this is true but I do know gas is going and it's going quick, quicker than the money coming in to pay for it
Justin Williams is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 2011 Chevrolet Cruze Sedan ECO LouisZX10R Garage Sale 1 11-03-2012 12:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome