Knock after Valve cover seal replacement - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 05-23-2012, 08:56 PM Thread Starter
Track Day Rider
 
WhackyWheels's Avatar
 
Join Date: Oct 2011
Location: Andrews AFB, MD
Posts: 173
Posting Frequency
 
Knock after Valve cover seal replacement

so when i turn it on it idles and keeps randomly knocking and the rpms spike about 200 each time that happens. any idea what could be wrong with it? no engine light.
WhackyWheels is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-23-2012, 10:15 PM Thread Starter
Track Day Rider
 
WhackyWheels's Avatar
 
Join Date: Oct 2011
Location: Andrews AFB, MD
Posts: 173
Posting Frequency
 
i seem to have fuel in my oil aswell, alot of fuel.

Last edited by WhackyWheels; 05-23-2012 at 10:17 PM.
WhackyWheels is offline  
post #3 of 9 Old 05-23-2012, 10:19 PM
Champion Rider
 
Join Date: Aug 2009
Location: michigan
Posts: 328
Posting Frequency
Images: 1
  
Valve cover wouldn't have anything to do with fuel in oil. Most likely a head gasket.

Sent from my LG-MS910 using Motorcycle.com Free App
shortskimper is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 05-23-2012, 10:19 PM
Champion Rider
 
Join Date: Aug 2009
Location: michigan
Posts: 328
Posting Frequency
Images: 1
  
Also. Check fuel pressure regulator.

Sent from my LG-MS910 using Motorcycle.com Free App
shortskimper is offline  
post #5 of 9 Old 05-23-2012, 11:18 PM Thread Starter
Track Day Rider
 
WhackyWheels's Avatar
 
Join Date: Oct 2011
Location: Andrews AFB, MD
Posts: 173
Posting Frequency
 

changed the oil just before the video and it doesn't seem to have fuel in it, must have been my imagination.

ha i kicked one of my empty beer bottles at the end XD. got pissed off by the unusual idle and started drinking.

Last edited by WhackyWheels; 05-23-2012 at 11:22 PM.
WhackyWheels is offline  
post #6 of 9 Old 05-23-2012, 11:23 PM
Gen2 Ripper
 
neverendingmods's Avatar
 
Join Date: Sep 2007
Location: The First State
Posts: 4,867
Posting Frequency
Images: 3
         
Make sure the coil caps are aligned properly. They are lines on top of cap and on valve cover. Sounds like it is mis firing and dumping fuel.
neverendingmods is offline  
post #7 of 9 Old 05-24-2012, 10:02 AM Thread Starter
Track Day Rider
 
WhackyWheels's Avatar
 
Join Date: Oct 2011
Location: Andrews AFB, MD
Posts: 173
Posting Frequency
 
it might be the spark plugs, the service manual fails to mention that you must screw in the coil plug not push it down. i pushed them down which strip the threading on the top of the spark plugs. going to the store now to buy new ones to see if it fixes it.
WhackyWheels is offline  
post #8 of 9 Old 05-24-2012, 12:00 PM
Champion Rider
 
Join Date: Aug 2009
Location: michigan
Posts: 328
Posting Frequency
Images: 1
  
Sounds like you got a winner. Keep us posted

Sent from my LG-MS910 using Motorcycle.com Free App
shortskimper is offline  
post #9 of 9 Old 05-24-2012, 12:57 PM Thread Starter
Track Day Rider
 
WhackyWheels's Avatar
 
Join Date: Oct 2011
Location: Andrews AFB, MD
Posts: 173
Posting Frequency
 
cleaned the throttle body with 99% isopropyl alcohol, replaced the spark plugs and cleaned out the coil packs with 99% isopropyl alcohol. installed them at the correct angle and it seems to be running correctly now.
WhackyWheels is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Fork Seal Replacement garth285 Performance and Tech 90 08-14-2019 11:26 PM
Valve cover gasket replacement interval Kawawog Performance and Tech 6 01-13-2012 07:13 PM
HOW TO: Fork Seal Replacement garth285 Performance and Tech 7 02-25-2009 12:28 PM
Fork seal replacement 2ligitninjas Performance and Tech 20 02-08-2008 08:50 AM
fork seal replacement logmaster Performance and Tech 7 06-11-2007 03:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome