Help with TRE install - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 08-25-2006, 10:57 PM Thread Starter
CMG
WSB Rider
 
Join Date: Aug 2006
Posts: 707
Posting Frequency
Images: 8
 
Help with TRE install

I have done some searches and read through all of them

I just got my TRE for the 06 model and am having some difficulty with reaching and disconnecting the grey connector.

first I have a few questions about removing the tank ( I know it's not needed but the connector seems to be in an impossible position to work with.

Question 1. When I disconnect the fuel line won't all the fuel in the tank drain onto the bike ? if yes what do you guys do to save the bike ?

Question 2. I am looking at the grey connector and I can't figure out how to open it, I know I have to remove two clips but I can't make em out, Any help Pics ?

Thanks
CMG is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 08-25-2006, 11:21 PM
 
Join Date: Jun 2006
Posts: 203
Posting Frequency
 
Ok answer to 1. just lay the tank side ways on a chair beside you(dont disconect) and to the 2 on the conector get a flat head screw driver and hold the lift lever thing down so it doesnt hold them together (forget about the other one) the put the screw driver in between and move it sideways like turning it. it is a bitch to get it off i went thru it youre gonna sweat like a biatch. remember to disconect the MIDDLE black and yellow wire(theres 2 of them).
T3MPO is offline  
post #3 of 10 Old 08-27-2006, 07:46 AM
Champion Rider
 
Join Date: Mar 2006
Location: CT
Posts: 384
Posting Frequency
 
Quote:
Originally Posted by CMG
I have done some searches and read through all of them

I just got my TRE for the 06 model and am having some difficulty with reaching and disconnecting the grey connector.

first I have a few questions about removing the tank ( I know it's not needed but the connector seems to be in an impossible position to work with.

Question 1. When I disconnect the fuel line won't all the fuel in the tank drain onto the bike ? if yes what do you guys do to save the bike ?

Question 2. I am looking at the grey connector and I can't figure out how to open it, I know I have to remove two clips but I can't make em out, Any help Pics ?

Thanks
q1 - no, the valve won't back drain, just whatever is in the line iteslf might come out..

q2 - no pics handy, but with these things, a very small 9jewlers0 flat blade screw diver can be of help. the retaining clips are oddly positioned, as I recall. aNd for Godssakes, searcg 06 TRE and 06 and perhaps my name to makes sure you use the correct wires in that plug, you'll know you got it wrong if your speedo stays at 0 mph permamently after you have done the install.
ctjackster is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 08-27-2006, 06:17 PM Thread Starter
CMG
WSB Rider
 
Join Date: Aug 2006
Posts: 707
Posting Frequency
Images: 8
 
well I had packed it in but T3 has convinced me to have another go at it,

I am attaching the two pictures can you maybe tell me what to do, I have a feeling that I am interpreting the directions completly wrong.

Last edited by CMG; 02-25-2007 at 02:51 PM.
CMG is offline  
post #5 of 10 Old 08-27-2006, 08:29 PM
Street Rider
 
Join Date: Jun 2006
Location: Miami, OK
Posts: 65
Posting Frequency
 
That connector is a real BITCH to get off. Not only does the clips hold it in there but the connector its self is a tight fit.
Smighter is offline  
post #6 of 10 Old 08-27-2006, 09:38 PM Thread Starter
CMG
WSB Rider
 
Join Date: Aug 2006
Posts: 707
Posting Frequency
Images: 8
 
got it the connectors off, I guess being pissed off is a prerequirement for the Job

had it not been for T3MPO I would have just given up and had a shop do it.

Now I hope the Airbox ain't gonna to be a bitch going back in.
CMG is offline  
post #7 of 10 Old 08-28-2006, 04:56 AM
 
Join Date: May 2006
Posts: 214
Posting Frequency
 
DON'T FORGET.... take the middle black and yellow wire out...if you don't..then speedo won't work
B1GPAP1 is offline  
post #8 of 10 Old 08-28-2006, 09:45 AM
Champion Rider
 
Join Date: Mar 2006
Location: CT
Posts: 384
Posting Frequency
 
Quote:
Originally Posted by B1GPAP1
DON'T FORGET.... take the middle black and yellow wire out...if you don't..then speedo won't work
yes that is the point I was trying to make, using the black/yellow wire from the "outside" of the group of wires (thus making it the easier and more likely, but wrong, choice) will let the TRE work but will lead to speedo not working, which will lead to much swearing as you again remove the tank, the airbox, the connector, etc.

Which is what I had to do, and would hope to save you from having to do.
ctjackster is offline  
post #9 of 10 Old 08-28-2006, 10:16 PM Thread Starter
CMG
WSB Rider
 
Join Date: Aug 2006
Posts: 707
Posting Frequency
Images: 8
 
Thanks guys, I finally finished, It feels like it took the punch out of the bike

don't get me wrong, It still pulls like the same when you get the rev's over 6K

but below that it feels weaker but not jerky anymore (which is what I wanted )

So far I'm happy with the upgrade.

Last edited by CMG; 08-28-2006 at 11:33 PM.
CMG is offline  
post #10 of 10 Old 08-28-2006, 11:42 PM
Champion Rider
 
Join Date: Mar 2006
Location: CT
Posts: 384
Posting Frequency
 
Quote:
Originally Posted by CMG
Thanks guys, I finally finished, It feels like it took the punch out of the bike

don't get me wrong, It still pulls like the same when you get the rev's over 6K

but below that it feels weaker but not jerky anymore (which is what I wanted )

So far I'm happy with the upgrade.

wow, not how I described it at all, definitely seemed to wake it up in the low revs for me (front wheel coming up sooner in the rev range is how I assessed the impact of the TRE on my 06). But, sounds like you are happy with the result.
ctjackster is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
TRE Install??? g-note Performance and Tech 11 05-24-2006 03:20 PM
Euro Install: Easiest Way to Re-install Inner Liner Under Headlight? IcePick06 Performance and Tech 18 12-30-2005 11:52 PM
help with the 1/5th install Rifleman The Out House 0 10-18-2005 10:36 PM
Install or not? BeepeR Performance and Tech 5 04-15-2005 12:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome