It Happened to me AGAIN! - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 52 Old 02-26-2010, 07:29 AM Thread Starter
Street Rider
 
BikeMaster's Avatar
 
Join Date: May 2009
Location: Bahrain -Middle East
Posts: 58
Posting Frequency
 
It Happened to me AGAIN!

Last nite was riding my 08 ZX10R normally..doing about 80kmph..went to open it up a bit and the clutch slipped..went to shift..but i couldnt shift the gear was stuck in 3rd gear..could not upshift nor downshift..stopped the bike on the side of the road..played with the clutch cable thinking i needed to pull it a bit more, but i could only put it gear with the bike off. brought it home..opened it up, the clutch basket broke from the tip and @ least one clutch broke..there were pieces on a clutch.
this happened to me before
https://www.zx-10r.net/forum/showthread.php?t=74242


Has this happened to anyone before or more than once?
When i did replace it the first time, i used a brand new OEM clutch basket and EBC Clutches/springs.
I dont understand why this is happening..the last time i was about to open it up it happened..this time same..The bike only has about 12000KMS and not abused. The last time i thought it was the poor choice of oil that caused that..but i was told here, its not the case, now the oil on the bike is due to be replaced..i havent done anything to the bike (mode wise) and other the the ocassional wheelie..its well taken care of.
Anyone know why or how to prevent this from happening?
Thanks in advance
BikeMaster is offline  
Sponsored Links
Advertisement
 
post #2 of 52 Old 02-26-2010, 07:52 AM
All show and all go 10r
 
JLG0987's Avatar
 
Join Date: May 2009
Location: BC, Canada
Posts: 5,921
Posting Frequency
         
wrong torque settings?
JLG0987 is offline  
post #3 of 52 Old 02-26-2010, 08:41 AM Thread Starter
Street Rider
 
BikeMaster's Avatar
 
Join Date: May 2009
Location: Bahrain -Middle East
Posts: 58
Posting Frequency
 
Quote:
Originally Posted by jlg0987 View Post
wrong torque settings?
Thanks for ur input, but i dont think that would be the case, as the wrong torque settings would have made worse damage, sooner than now.
BikeMaster is offline  
Sponsored Links
Advertisement
 
post #4 of 52 Old 02-26-2010, 08:44 AM Thread Starter
Street Rider
 
BikeMaster's Avatar
 
Join Date: May 2009
Location: Bahrain -Middle East
Posts: 58
Posting Frequency
 
Some shots..









BikeMaster is offline  
post #5 of 52 Old 02-26-2010, 09:12 AM
Champion Rider
 
Join Date: Sep 2009
Posts: 427
Posting Frequency
  
Normally what breaks the clutch basket is the broken clutch plate. The pieces can get caught between the inner, and outer basket and breaks it. Stop useing junk aftermarket clutch plates. You should never use anything but factory clutch plates. The EBC plates are weak, but they are not as bad as Barnett which are the biggest pieces of junk ever invented. Mike.
880turbo is offline  
post #6 of 52 Old 02-26-2010, 09:16 AM
All show and all go 10r
 
JLG0987's Avatar
 
Join Date: May 2009
Location: BC, Canada
Posts: 5,921
Posting Frequency
         
Personally I find the 08s to have shitty transmissions. I pretty sure I'm going to have some major problems this year thank god I still have warrenty.
JLG0987 is offline  
post #7 of 52 Old 02-26-2010, 10:22 AM Thread Starter
Street Rider
 
BikeMaster's Avatar
 
Join Date: May 2009
Location: Bahrain -Middle East
Posts: 58
Posting Frequency
 
Quote:
Originally Posted by 880turbo View Post
Normally what breaks the clutch basket is the broken clutch plate. The pieces can get caught between the inner, and outer basket and breaks it. Stop useing junk aftermarket clutch plates. You should never use anything but factory clutch plates. The EBC plates are weak, but they are not as bad as Barnett which are the biggest pieces of junk ever invented. Mike.
I doubt that as the first time it happened, it had OEM clutches/plates/springs. The only reason i installed them was for longer life. I have installed these clutches on my 08 busa and my 06 Gixxer1000 and i have never had to look back, its only the ZX10R..I'm going to have to replace them, fine, but i would like to know what reason this happened and if its happened to ppl once or more who are 08 Zx10 owners.
the Dealership here is a waste of time and the only thing they maybe good @ it repairing generators they are not up to any standard @ all so im on my own on this, either that or take it to the Suzuki agent who are more reliable but ill have to pull some strings.
If you notice that the time frame between the two mishaps is not too long (05-08-2009) around 9 months later i'm back facing the same issue.. ( just thinking..9 months later it Pops..lol)
Could the Shift Rod have anything to do with this issue? I have read a thread here stating that there issues with the Factory Shift Rods.
BikeMaster is offline  
post #8 of 52 Old 02-26-2010, 11:48 AM
WSB Rider
 
Jazzmaster71's Avatar
 
Join Date: Jan 2007
Location: Norway
Posts: 620
Posting Frequency
 
First time I heard someone have this problem on the 08. I can't imagin what have caused that mess, good luck putt'in it together.
Jazzmaster71 is offline  
post #9 of 52 Old 02-26-2010, 12:32 PM
WSB Rider
 
redline659's Avatar
 
Join Date: May 2007
Posts: 819
Posting Frequency
  
Get a dragpack from Cycle Concepts. Better than OEM and will last longer too, oh and its cheaper

803-285-8093

His name is Dwayne,
redline659 is offline  
post #10 of 52 Old 02-26-2010, 01:04 PM
GP Rider
 
spikespiegel's Avatar
 
Join Date: Mar 2008
Location: Folsom, CA
Posts: 1,274
Posting Frequency
Images: 8
    
Send a message via AIM to spikespiegel Send a message via Yahoo to spikespiegel
anyone that claims the 08 zx10r tranny is crap is on CRACK. I know a lot of people with the 08s and i've never heard any complaints re; the clutch breaking or tranny issues. I beat my bike on the track too, 12k miles and still orig clutch and everything.. Not sure what the issue is, hope you get it worked out
spikespiegel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
it happened rocketracermike The Out House 88 08-20-2007 09:45 PM
What happened next??? fpzx10 Pictures and Videos 9 05-18-2007 06:38 PM
What happened after this zx10x2 The Out House 1 06-09-2006 03:45 PM
What happened??? 1kdoubler The ZX-10R 4 03-22-2006 07:18 PM
Has this Ever Happened to you Sgtusmc96 Pictures and Videos 15 10-19-2005 02:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome