Got the starrotor hId kit on second gen, Im lost - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 04-17-2009, 03:43 AM Thread Starter
GP Rider
 
xx8055NIACxx's Avatar
 
Join Date: Mar 2009
Location: Seattle
Posts: 1,436
Posting Frequency
       
Got the starrotor hId kit on second gen, Im lost

can you guys show me some pics of how you guys installed those lights in to the light housing

im not able to get mine in

thx






EDIT

I just talked to Rick at StarRotors.com

He sent me two the Right Bulbs, two fro 30 bucks, at half price, I am the one that ordered the wrong bulbs in the first place

the guy is a standup dude, great seller and a great business owner

Sent me the new bulbs for half the price after it was my mistake ordering the wrong bulbs, for some reason I ordered the H1 and H7

thx Rick

Last edited by xx8055NIACxx; 04-17-2009 at 08:58 PM.
xx8055NIACxx is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 04-17-2009, 08:07 AM
Champion Rider
 
Yourmyboyblue3's Avatar
 
Join Date: Jan 2008
Location: Orlando, FL
Posts: 299
Posting Frequency
 
Quote:
Originally Posted by xx8055NIACxx View Post
can you guys show me some pics of how you guys installed those lights in to the light housing

im not able to get mine in

thx
I don't have any PIC's but if you tell me where your lost I can check my bike to help you out?
Yourmyboyblue3 is offline  
post #3 of 18 Old 04-17-2009, 10:12 AM
GP Star
 
kawi1000's Avatar
 
Join Date: May 2006
Location: NORCAL
Posts: 3,449
Posting Frequency
Images: 26
       
They are plug and play. Which are you having problem with? takes only 15 min to install. If you have the slim ballast you can put velcro both on the nose of the front cowl thats how I did it, pretty much the harderst thing to do is to find place for the ballast.
kawi1000 is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old 04-17-2009, 10:13 AM
Champion Rider
 
Yourmyboyblue3's Avatar
 
Join Date: Jan 2008
Location: Orlando, FL
Posts: 299
Posting Frequency
 
Yourmyboyblue3 is offline  
post #5 of 18 Old 04-17-2009, 01:30 PM Thread Starter
GP Rider
 
xx8055NIACxx's Avatar
 
Join Date: Mar 2009
Location: Seattle
Posts: 1,436
Posting Frequency
       
than I must have gotten the wrong kit guys, the bulbs go right throught the light housing, and the rubber seal on the back is too big to install on the bike


the original light fits tightly and snug, the new light just goes through the housing as its too small and ends up inside the projector the bulb wire and everything else

shit is pissing me off
xx8055NIACxx is offline  
post #6 of 18 Old 04-17-2009, 01:48 PM Thread Starter
GP Rider
 
xx8055NIACxx's Avatar
 
Join Date: Mar 2009
Location: Seattle
Posts: 1,436
Posting Frequency
       
looks like I got the H7 and H1 bulbs, I need the H11 and H9 for my bike

I wonder if they will sell me the bulbs alone.
xx8055NIACxx is offline  
post #7 of 18 Old 04-17-2009, 04:44 PM
Champion Rider
 
Yourmyboyblue3's Avatar
 
Join Date: Jan 2008
Location: Orlando, FL
Posts: 299
Posting Frequency
 
Quote:
Originally Posted by xx8055NIACxx View Post
looks like I got the H7 and H1 bulbs, I need the H11 and H9 for my bike

I wonder if they will sell me the bulbs alone.
You should be able to exchange them for the ones you need. Email them what happen and they should exchange the kit, here try this #636-293-2073. After that DUDE no joke the install will take you 10 minutes tops. what color did you get the bulbs in???

Last edited by Yourmyboyblue3; 04-17-2009 at 04:49 PM.
Yourmyboyblue3 is offline  
post #8 of 18 Old 04-17-2009, 04:52 PM Thread Starter
GP Rider
 
xx8055NIACxx's Avatar
 
Join Date: Mar 2009
Location: Seattle
Posts: 1,436
Posting Frequency
       
I got the 6000k white, will give them a call man and see what we can do

thx for your help bro
xx8055NIACxx is offline  
post #9 of 18 Old 04-17-2009, 04:54 PM
Champion Rider
 
Yourmyboyblue3's Avatar
 
Join Date: Jan 2008
Location: Orlando, FL
Posts: 299
Posting Frequency
 
Anytime man...
Yourmyboyblue3 is offline  
post #10 of 18 Old 04-17-2009, 05:06 PM
GP Rider
 
superman10r's Avatar
 
Join Date: Jun 2007
Location: sc
Posts: 1,775
Posting Frequency
Images: 5
       
Quote:
Originally Posted by xx8055NIACxx View Post
I got the 6000k white, will give them a call man and see what we can do

thx for your help bro
It's what I have and you will love the lights. Makes a world of difference in lighting.
superman10r is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
lost key dbltakeZX10 The ZX-10R 13 06-18-2010 07:28 PM
StarRotor HID Kit silverbullet2005 The ZX-10R 168 05-31-2009 10:34 AM
Who Lost This ? 10 nw ga. The Out House 15 11-29-2007 11:48 AM
Lost my key! 1killer1liter The ZX-10R 21 09-14-2005 05:25 AM
lost key fbdr24 The ZX-10R 31 08-20-2005 03:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome