Gen3 coils in a gen2 YES! - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-14-2011, 04:04 PM Thread Starter
GP Rider
 
TexasRider's Avatar
 
Join Date: Aug 2010
Location: Mesquite, Tx
Posts: 1,413
Posting Frequency
      
Gen3 coils in a gen2 YES!

Ok...after my low speed (idle to 3000rpm ) issues, https://www.zx-10r.net/forum/showthread.php?t=101846 I ended up deciding it was a coil pack gone bad. Even though there was no FI light tripped. Was told by a few ppl bad coils may not throw up a code, I found a set of coil packs off an 08 ZX10 on ebay for $45 shipped! Got em delivered yesterday, and installed them today. I went ahead and changed them all since 4 numbers on the 07 sticks didnt match the 08. Other than that they are EXACTLY the same size, wt and all. Put em in and the bike fired right up. Let her warm up to temp and she purrs like a kitten. Went for a short (2 mile) ride and she seems to be back to her beastly self. Pulls from a dead stop off idle thru and past 3000rpm with no stumble or hesitation. Wont have much chance the rest of the weekend to ride, but so far im happy to have seemed to fix her myself and save at least $400 by not just truckin her to the stealership! Oh...anyone that says ya HAVE to pull the upper outside mounts and brackets to get the coil packs in and out of #1 and 4...your wrong. I was able to get them out/in without removing the brackets. Took a few minutes of careful bending and pulling/pushing but it can be done.

Faster than a drunk snail on valium!

07 zx10r- stolen
New bike...07 GSXR1000..BMC filter, LOR slip on, 520 conversion with -1, speedohealer, pc3 custom map with xtre settings, Galfer superbike lines front, galfer sportbike line rear, shorty levers, Yami R1 throttle tube for 1/5 throttle, PAIR mod, exhaust valve gone, ecu flashed.
TexasRider is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-14-2011, 05:31 PM
GP Star
 
zx racer's Avatar
 
Join Date: Feb 2010
Location: Scottsboro, AL
Posts: 3,763
Posting Frequency
      
glad to see you got her fixed did you change the plugs also ?

05 ZX-10R SWB.

Last edited by zx racer; 05-14-2011 at 05:34 PM.
zx racer is offline  
post #3 of 6 Old 05-14-2011, 06:10 PM Thread Starter
GP Rider
 
TexasRider's Avatar
 
Join Date: Aug 2010
Location: Mesquite, Tx
Posts: 1,413
Posting Frequency
      
Quote:
Originally Posted by zx racer View Post
glad to see you got her fixed did you change the plugs also ?
Nope...plugs were good. Only like 2000 miles on em. So...im hoping it was just a coil takin a turd and not the ecu starting to fry. If i have troubles again...ill be hunting an ecu off ebay.

Faster than a drunk snail on valium!

07 zx10r- stolen
New bike...07 GSXR1000..BMC filter, LOR slip on, 520 conversion with -1, speedohealer, pc3 custom map with xtre settings, Galfer superbike lines front, galfer sportbike line rear, shorty levers, Yami R1 throttle tube for 1/5 throttle, PAIR mod, exhaust valve gone, ecu flashed.
TexasRider is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-15-2011, 04:56 AM
Late Apex
 
Solo-Six's Avatar
 
Join Date: Mar 2010
Location: Norcal
Posts: 803
Posting Frequency
  
Quote:
Originally Posted by TexasRider View Post
Ok...after my low speed (idle to 3000rpm ) issues, https://www.zx-10r.net/forum/showthread.php?t=101846 I ended up deciding it was a coil pack gone bad. Even though there was no FI light tripped. Was told by a few ppl bad coils may not throw up a code, I found a set of coil packs off an 08 ZX10 on ebay for $45 shipped! Got em delivered yesterday, and installed them today. I went ahead and changed them all since 4 numbers on the 07 sticks didnt match the 08. Other than that they are EXACTLY the same size, wt and all. Put em in and the bike fired right up. Let her warm up to temp and she purrs like a kitten. Went for a short (2 mile) ride and she seems to be back to her beastly self. Pulls from a dead stop off idle thru and past 3000rpm with no stumble or hesitation. Wont have much chance the rest of the weekend to ride, but so far im happy to have seemed to fix her myself and save at least $400 by not just truckin her to the stealership! Oh...anyone that says ya HAVE to pull the upper outside mounts and brackets to get the coil packs in and out of #1 and 4...your wrong. I was able to get them out/in without removing the brackets. Took a few minutes of careful bending and pulling/pushing but it can be done.
I agree it can be done .. the right stick is a tight fit but the left stick is just a lil trick . pull up to the frame . lean it inline with frame towards the front and lift n roll. slides right out


________________Grip It And Rip It_________________
Solo-Six is offline  
post #5 of 6 Old 05-15-2011, 07:12 AM Thread Starter
GP Rider
 
TexasRider's Avatar
 
Join Date: Aug 2010
Location: Mesquite, Tx
Posts: 1,413
Posting Frequency
      
Quote:
Originally Posted by Solo-Six View Post
I agree it can be done .. the right stick is a tight fit but the left stick is just a lil trick . pull up to the frame . lean it inline with frame towards the front and lift n roll. slides right out
I actually found the right (#4) to be easier. lift..push to the front and out it came. The left (#1) up, pulled towards the inside and kept tugging til she came out. Installing it was more of a bugger lol.

Faster than a drunk snail on valium!

07 zx10r- stolen
New bike...07 GSXR1000..BMC filter, LOR slip on, 520 conversion with -1, speedohealer, pc3 custom map with xtre settings, Galfer superbike lines front, galfer sportbike line rear, shorty levers, Yami R1 throttle tube for 1/5 throttle, PAIR mod, exhaust valve gone, ecu flashed.
TexasRider is offline  
post #6 of 6 Old 05-15-2011, 07:21 AM
BANNED
 
Join Date: Aug 2010
Location: STL
Posts: 1,516
Posting Frequency
  
good to hear
hellboytt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen2 and Gen3 Race / Suspension Manuals Solo-Six Performance and Tech 2 05-09-2011 11:34 AM
Gen 2: Gen3 Dash on a Gen2 Chuck Norris Performance and Tech 0 02-28-2011 03:56 AM
Gen3 to Gen2 Nutter34 The ZX-10R 7 12-01-2010 12:54 AM
gen3 wheels on gen2 edouble The ZX-10R 3 06-11-2010 06:26 PM
Lots of gen1/gen2/gen3 oem and aftermarket parts Lucky10R Parts, Gear and Accessories 22 10-05-2009 08:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome