Gen 1 fuel pump not getting power ??? - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-22-2019, 08:49 AM Thread Starter
Squid
 
Join Date: Jan 2019
Posts: 3
Posting Frequency
 
Gen 1 fuel pump not getting power ???

Hi I'm not getting power to my fuel pump no priming noise and have checked with a metre any ideas on what I can check out next as it's really frustrating me now
Denred is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-22-2019, 11:52 AM
Kawasaki Whisperer
 
MrMoto73's Avatar
 
Join Date: Aug 2014
Location: Pueblo Colorado
Posts: 1,687
Posting Frequency
   
Send a message via MSN to MrMoto73
I am guessing you checked your fuses and grounds? Does it have a power commander? Also there are a couple of sensors that cut power to the pump. Lean angle sensor, kick stand sensor.... can't remember what other ones.

I DON"T HAZ ANY SNYDER PROBLEMS
MrMoto73 is offline  
post #3 of 3 Old 01-22-2019, 10:40 PM
gaz
Track Day Rider
 
Join Date: Aug 2017
Location: monroe ga.
Posts: 217
Posting Frequency
  
as stated ck kickstand switch. i've had 2 10's lost pump power. after switch first place i would go is the common ground box located in wiring harness directley at the end of the negative battery cable. rectangular plastic box taped up in main wiring harness close to where fuel pump power plug comes out. serves as ground for several sensors/systems. untape and pry apart to ck for burnt wiring/corossion. also common +12v box same position can cause multiple problems. spent hours chasing down the first one, had a burnt wire, next one was corossion problem, repaired/cleaned pump power restored. not hard to check.
gaz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Removed tank, fuel pump trickling fuel constant neverendingmods Performance and Tech 9 07-21-2019 06:13 PM
fuel injector or fuel pump??? Dnicezx10r The ZX-10R 2 12-13-2011 07:16 AM
Fuel Injectors and Fuel Pump Crazi Parts, Gear and Accessories 0 10-21-2009 07:42 PM
Fuel pump gone...inline pump and regulator? bugman53 Performance and Tech 15 05-18-2008 10:39 AM
WTB Fuel tank/Fuel pump bellevuetlr Wanted: Buy or Trade 2 12-13-2005 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome