Gen 1: 2004-2005 Fuel pump??????? - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 09-04-2012, 07:18 AM Thread Starter
GP Star
 
tone.r's Avatar
 
Join Date: Oct 2007
Location: CIN-OHIO
Posts: 2,297
Posting Frequency
  
Fuel pump???????

WELL this just started yesterday i was about to go for a ride BUT the fuel pump would'nt come on:dontknow, this just started out of the blue does anybody have ant idea what the hell could be going on?

I did check the plug
I checked the fuse box
I made sure the battery was 100% chargered up
I put my spare pump on the bike still nothing
HELP

Tone.R {checkmate}
Do what makes u happy whatever it is.....Roberson Racing
tone.r is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 09-04-2012, 08:31 AM
Champion Rider
 
ZxTennessee's Avatar
 
Join Date: Sep 2010
Location: Portland, Tn.
Posts: 270
Posting Frequency
 
Take off your tank and fuel pump and turn on key with run switch off, get your multi meter ready then flip the run switch to on and test the wires going away from the tank and pump to make sure they have power, if so then you can plug your pump in and put your ear right up to it and listen for noise, or get 2 wires and run from batt to fuel pump and see if it runs the pump. Then you will know if it is the pump or not

ps make sure there is gas in the tank

Last edited by ZxTennessee; 09-04-2012 at 08:41 AM.
ZxTennessee is offline  
post #3 of 17 Old 09-04-2012, 12:32 PM
WSB Rider
 
badassjake's Avatar
 
Join Date: Jun 2010
Location: Atlantic CANADA
Posts: 944
Posting Frequency
 
the relay box may have crapped out on you....the little black box with the 2 connectors on the top of the ECU.

2004 ZX10R-few mods here and there......
and even made more Evil by Woolich.
badassjake is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 09-04-2012, 12:44 PM
GP Rider
 
PatrickG's Avatar
 
Join Date: Dec 2005
Location: Elizabethtown, KY
Posts: 1,802
Posting Frequency
Images: 15
      
Tony check the connector on the main wiring harness behind the left side cover. It's taped up with the harness, mine did the same thing. I moved the wiring around and the fuel pump kicked on immediately. It is a 10-12 pin connector and it corrods and burns itself up.

2005 ZX-10R Akrapovic Ti Evo 2 w/CF LOR can, PC3 with custom map, Factory Pro velocity stacks

2009 ZX-10r Full Gen4 Brock's SS exhaust with CF 14" can, PC3, Secondary Butterflies Removed, Kawasaki Race Exhaust Cam, My Own TRE, Degreed Cams 109/108

2011 zx10r Lower'd 2" Frt & Rear, Stretched 8", Graves CF slipon, GUHL Flashed ECU

Last edited by PatrickG; 09-04-2012 at 12:49 PM.
PatrickG is offline  
post #5 of 17 Old 09-04-2012, 01:43 PM
Does not drive into smoke
 
El Zilcho's Avatar
 
Join Date: Apr 2010
Location: Austin, TX
Posts: 2,156
Posting Frequency
       
Kill switch?
El Zilcho is offline  
post #6 of 17 Old 09-04-2012, 04:31 PM
Track Day Rider
 
Austinjval's Avatar
 
Join Date: Mar 2012
Posts: 122
Posting Frequency
  
Same problem with my bike, I'll be watching this thread as well. Here's a link to mine that has a lot of suggestions. Good luck and keep me posted if you figure it out.

https://www.zx-10r.net/forum/showthread.php?t=119049
Austinjval is offline  
post #7 of 17 Old 09-04-2012, 04:44 PM Thread Starter
GP Star
 
tone.r's Avatar
 
Join Date: Oct 2007
Location: CIN-OHIO
Posts: 2,297
Posting Frequency
  
Quote:
Originally Posted by Austinjval View Post
Same problem with my bike, I'll be watching this thread as well. Here's a link to mine that has a lot of suggestions. Good luck and keep me posted if you figure it out.

https://www.zx-10r.net/forum/showthread.php?t=119049
thx i seen yours yesterday i was having something like what your having going on 2 months ago it was my battery plus connector that goes to the relay on the right side

Tone.R {checkmate}
Do what makes u happy whatever it is.....Roberson Racing
tone.r is offline  
post #8 of 17 Old 09-04-2012, 04:46 PM Thread Starter
GP Star
 
tone.r's Avatar
 
Join Date: Oct 2007
Location: CIN-OHIO
Posts: 2,297
Posting Frequency
  
thx guys i will check when i get home from work today, its crazy because i was just riding the bike the day before

Tone.R {checkmate}
Do what makes u happy whatever it is.....Roberson Racing
tone.r is offline  
post #9 of 17 Old 09-04-2012, 05:47 PM
WSB Rider
 
badassjake's Avatar
 
Join Date: Jun 2010
Location: Atlantic CANADA
Posts: 944
Posting Frequency
 
i did have the fuel circut in the ECU shit the bed too....it was self induced, everythign worked perfect, except the fuel pump priming........replaced the ECU and all went back to normal.

2004 ZX10R-few mods here and there......
and even made more Evil by Woolich.
badassjake is offline  
post #10 of 17 Old 09-04-2012, 09:37 PM Thread Starter
GP Star
 
tone.r's Avatar
 
Join Date: Oct 2007
Location: CIN-OHIO
Posts: 2,297
Posting Frequency
  
might sound crazy but i think it was not having my front sprocket cover on, I put my cover back on now my pump is working again crazy, it must be a ground im thinking

Tone.R {checkmate}
Do what makes u happy whatever it is.....Roberson Racing
tone.r is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Removed tank, fuel pump trickling fuel constant neverendingmods Performance and Tech 9 07-21-2019 06:13 PM
fuel injector or fuel pump??? Dnicezx10r The ZX-10R 2 12-13-2011 07:16 AM
Fuel Injectors and Fuel Pump Crazi Parts, Gear and Accessories 0 10-21-2009 07:42 PM
Fuel pump gone...inline pump and regulator? bugman53 Performance and Tech 15 05-18-2008 10:39 AM
WTB Fuel tank/Fuel pump bellevuetlr Wanted: Buy or Trade 2 12-13-2005 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome