Gen 4: 2011-2015 Fuel pressure/delivery issue? - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-20-2018, 07:54 PM Thread Starter
arc
Champion Rider
 
arc's Avatar
 
Join Date: Jan 2011
Location: Melbourne, Australia
Posts: 305
Posting Frequency
 
Question Fuel pressure/delivery issue?

2014 ZX-10R, AU model, 110,000 kms, Akra slip on + link pipe, Annatori quick shifter.

Symptom: wide band sensor goes very high (17-21 AFR) on very mild acceleration, worse at higher RPMS, less bad going up into higher gears at static RPM. Full roll and and the bike will stall (unconfirmed). Was worse when the tank showed the reserve light, now consistently bad. Initially happened only at full roll on, been getting worse over the last 5,000 kms or so, now happens even with very slight throttle.

Tried so far: new fuel pump (aftermarket internal), new fuel filter (was very dirty) and new fuel pressure regulator. Tank cleaned, injector cleaner used multiple times. New spark plugs. No fuel line leaks. Fuel rail seems OK. Applied stock fuel map (using Woolich Racing reflash). Happens in Low, Medium and Full power modes. Doesn't appear to happen in neutral (no load though). Air filter OK, no leaks in air box. Fuel pump primes OK when ignition switched on. Woolich log box showing throttle position sensor opening up. Seems to happen in both IAP and TPS maps (it only takes a very slight roll on now for the issue to show).

Any ideas? Bike unusable like this :(

Thanks for your help,
A.

Tomorrow, when I wake, or think I do, what shall I say of today?
Samuel Beckett, Waiting for Godot
arc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-20-2018, 07:58 PM
GP Star
 
thundercoupe9's Avatar
 
Join Date: Apr 2012
Location: ST. LOUIS
Posts: 2,158
Posting Frequency
  
Check fuel pressure while riding with a gauge.
thundercoupe9 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
fuel power loss afr

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen 1: Low fuel pressure ninja10kid The ZX-10R 12 12-11-2013 07:48 AM
Oil pressure issue dabl131 The ZX-10R 9 05-28-2012 07:01 PM
? about fuel tank pressure Only_One_R1 ZX-14 Discussion 1 03-06-2011 08:20 PM
Problem tuning my bike, no top end fuel delivery. customspeed The ZX-10R 5 09-13-2010 08:57 PM
Final word on 06' Fuel Delivery Auron The ZX-10R 13 04-30-2006 01:00 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome