Gen 3: 2008-2010 Front brake issue - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-02-2013, 08:41 AM Thread Starter
WSB Rider
 
fastburnzx-10's Avatar
 
Join Date: Aug 2005
Location: Ft.Hood TX
Posts: 681
Posting Frequency
  
Send a message via AIM to fastburnzx-10 Send a message via MSN to fastburnzx-10
Front brake issue

I did some searching around and I cant seem to find anything on here about stiff brakes.

Here is the issue, Rode the bike up to work the other week and I noticed on the ride that the front brakes took alot of lever input to stop.

I tried adjusting the levers but it still feels the same no matter what setting i put it on.

3rd gen 08 with 39K on it.

I am thinking mastercylinder,
what do you all think?

Ride hard, ride fast....

08 ZX-10R (Black)
05 zx-10r (magma)-KIA---
73 Z1 900 (all original)-The Original Kawi beast
fastburnzx-10 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-02-2013, 08:48 AM
Track Day Rider
 
ndob1's Avatar
 
Join Date: Dec 2010
Posts: 181
Posting Frequency
  
Try bleeding and changing the fluid. I use motul rbf660 . never had issue . but i bleed with every brake pad change or 20k km . If you havent got steel braided hoses u can get them .
check the pads and rotors too..
ndob1 is offline  
post #3 of 6 Old 07-02-2013, 09:24 AM
REPOST Enforcement Mod
 
SkyDork's Avatar
 
Join Date: Feb 2006
Location: Wesley Chapel, FL
Posts: 13,532
Posting Frequency
           
Garage
What do you mean by stiff brakes? Like you pull them real hard and the bike doesn't want to stop? Or just like the lever is sticking or hard to move by itself? What maintenance have you performed on the brake system over it's life?

Disassemble the lever and grease the pivot bolt, adjuster and master cylinder push pin that goes into the lever. when was your last fluid change? Change the brake fluid and rebleed the entire system. What is the condition of the pads? Check the wear bars on the pads and replace them if too low. Clean and lubricate the caliper pistons to remove the gunk and clean and lube the pad retention pins in there. Exercise the pistons in the calipers by hand to make sure they retract all the way as well.

I may not be perfect, but at least I don't ride a Suzuki.

Ridding the Internet of bad grammar, 1 post at a time.
#WordCrimes




SkyDork is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 07-02-2013, 02:15 PM Thread Starter
WSB Rider
 
fastburnzx-10's Avatar
 
Join Date: Aug 2005
Location: Ft.Hood TX
Posts: 681
Posting Frequency
  
Send a message via AIM to fastburnzx-10 Send a message via MSN to fastburnzx-10
Older Guy had it before me, I've never done a fluid swap, but I think I have only put about 2K on the odometer since he had it. THe brakes are running around 40-50% of friction material. Stiff as in i pull the lever and it doesnt stop as easy as it did. The lever itself seems to be moving fine

Thank you for the good information, I'll try to bleed the system and see how it goes.

Ride hard, ride fast....

08 ZX-10R (Black)
05 zx-10r (magma)-KIA---
73 Z1 900 (all original)-The Original Kawi beast
fastburnzx-10 is offline  
post #5 of 6 Old 07-02-2013, 09:03 PM
Squid
 
Join Date: May 2013
Posts: 40
Posting Frequency
 
I think it would be best if you can drain the brake fluid and change the brake pads as part of the periodic maintenance. Make sure to bleed the system completely making sure that the there is no leak. If problem still persist, check the caliper and brake master.
kartl is offline  
post #6 of 6 Old 07-03-2013, 07:54 AM Thread Starter
WSB Rider
 
fastburnzx-10's Avatar
 
Join Date: Aug 2005
Location: Ft.Hood TX
Posts: 681
Posting Frequency
  
Send a message via AIM to fastburnzx-10 Send a message via MSN to fastburnzx-10
Thanks for the help guys

Ride hard, ride fast....

08 ZX-10R (Black)
05 zx-10r (magma)-KIA---
73 Z1 900 (all original)-The Original Kawi beast
fastburnzx-10 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High speed front brake vibration issue STurner Performance and Tech 30 03-26-2013 09:38 PM
Brake issue hotglue The ZX-10R 22 05-13-2009 08:07 PM
05 front brake issue (636 mc) wicked Performance and Tech 3 05-23-2008 09:41 AM
Front Brake issue hotfocuson18s The ZX-10R 12 05-29-2007 05:52 PM
Brake issue? K10 Performance and Tech 8 08-12-2005 10:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome