Error code 25 - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 04-03-2009, 02:05 PM Thread Starter
Squid
 
Join Date: Mar 2009
Posts: 8
Posting Frequency
 
Error code 25

Can anyone help me identify the error with code 25? The bike runs fine as has no loss of power but I am getting some sort of error since the FI light keeps flashing. And the error code is 25, what error is this?
2K6-ZX10R is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 04-03-2009, 02:23 PM
Champion Rider
 
LaurenOE's Avatar
 
Join Date: Dec 2008
Location: Orlando
Posts: 399
Posting Frequency
  
Send a message via AIM to LaurenOE
On a 2008 ZX10R, Error code 25 is the gear position switch. "If the gear position switch system fails, (no signal, wiring short or open), the ECU sets the top (6th) gear position."
LaurenOE is offline  
post #3 of 14 Old 04-03-2009, 02:34 PM Thread Starter
Squid
 
Join Date: Mar 2009
Posts: 8
Posting Frequency
 
Oh I forgot the bike is a 2006 model. But actually the light came on the instant I put it into first gear, so it might be something like that. Does anyone know if error code 25 means the same on 2006 as the 2008?
2K6-ZX10R is offline  
Sponsored Links
Advertisement
 
post #4 of 14 Old 04-04-2009, 02:13 AM
WSB Rider
 
sextaafondo's Avatar
 
Join Date: Oct 2007
Location: Buenos Aires-Argentina
Posts: 742
Posting Frequency
   
Yes, it is.
G.P.S. error.
sextaafondo is offline  
post #5 of 14 Old 04-08-2009, 05:49 AM Thread Starter
Squid
 
Join Date: Mar 2009
Posts: 8
Posting Frequency
 
Could one of you provide me with info on where to find this GPS sensor and maybe with a picture to illustrate?
2K6-ZX10R is offline  
post #6 of 14 Old 04-08-2009, 09:13 AM
GP Star
 
tasos's Avatar
 
Join Date: Feb 2005
Location: Cyprus, Europe
Posts: 2,658
Posting Frequency
Images: 8
       
Send a message via Yahoo to tasos
Here
Attached Thumbnails
Click image for larger version

Name:	page1.jpg
Views:	857
Size:	108.1 KB
ID:	92944   Click image for larger version

Name:	page2.jpg
Views:	764
Size:	88.8 KB
ID:	92945  
tasos is offline  
post #7 of 14 Old 04-08-2009, 09:18 AM
GP Star
 
tasos's Avatar
 
Join Date: Feb 2005
Location: Cyprus, Europe
Posts: 2,658
Posting Frequency
Images: 8
       
Send a message via Yahoo to tasos
The actual sensor is on the first page, on the third picture under the chain.

Remove it, clean it and put it back. If it's still not working, check the connection wire on the throttle bodies /replace sensor(second page, first picture -C-). Hope this helps.
tasos is offline  
post #8 of 14 Old 04-10-2009, 05:45 AM Thread Starter
Squid
 
Join Date: Mar 2009
Posts: 8
Posting Frequency
 
Thank you so much. That was very very helpful, i will try that and see if it helps. Will it harm the bike to drive with a broken GPS sensor? It feels like it deliveres full power, and as i understand the bike will think it is in 6th if the sensor is not working and therefore i must get a richer a/f than else in the lower gears which will not be as harmfull as a lean mixture, but i might be missing something?
2K6-ZX10R is offline  
post #9 of 14 Old 04-10-2009, 06:17 AM
GP Star
 
tasos's Avatar
 
Join Date: Feb 2005
Location: Cyprus, Europe
Posts: 2,658
Posting Frequency
Images: 8
       
Send a message via Yahoo to tasos
Glad to help . It's better to fix/replace it. Richer mixtures can cause damage too (higher temps etc). Maybe it needs some cleaning, this is a "critical" sensor, if it was totally gone the bike wouldn't start.
tasos is offline  
post #10 of 14 Old 04-10-2009, 06:23 AM
GP Rider
 
Join Date: Feb 2009
Location: overseas soon florida
Posts: 1,978
Posting Frequency
  
Send a message via Yahoo to wildcats
damn he did everything but do it for ya lol good shit
wildcats is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
error code 63 '05 10R Tailgunner Performance and Tech 7 06-17-2009 10:20 PM
FI error code 34 ash01s2001 Performance and Tech 10 11-03-2008 07:58 PM
Error Code 62 afskypilot Performance and Tech 2 04-19-2008 01:37 AM
kawi race ecu error code question 10rmotor Performance and Tech 8 01-08-2007 11:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome