dyno-jet quickshifter problem - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-29-2007, 11:58 PM Thread Starter
Track Day Rider
 
nelly250's Avatar
 
Join Date: Jan 2007
Posts: 123
Posting Frequency
 
dyno-jet quickshifter problem

I lowsided on the weekend and the wire ripped out of the base of my dyno-jet quickshifter. Is there anyway to open the quickshifter so i can attempt to rewire it or does anyone have any better ideas? Cheers

04zx10r - Yosh rs3 s/o ^ Ohlins Damper ^ Penske 8987 ^ Traxxion Forks ^ Woodcraft Rearsets ^ PC3usb ^ DJ Quickshifter ^ Radial 6rr Master ^ Galfer lines ^ 1/5 throttle ^ 636 linkage ^ Renthal 15-42 ^ 520 conversion ^ Double Screen ^ K&N Filter ^ Champ Sliders ^ Flexiglass Race Bodywork
nelly250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
quickshifter ? jayrc30 Performance and Tech 35 09-04-2009 11:08 PM
dyno-jet quickshifter problems nelly250 Performance and Tech 7 05-18-2007 12:42 AM
Dyno Quickshifter Problem Slims10R Performance and Tech 6 05-16-2007 12:21 PM
quickshifter rroobb Performance and Tech 10 05-03-2007 07:10 AM
USB Powercommander Quickshifter problem RikP Performance and Tech 8 03-14-2007 07:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome