DDM Tuning HID kit Problem - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-24-2010, 12:54 PM Thread Starter
Squid
 
Join Date: Mar 2010
Posts: 12
Posting Frequency
 
DDM Tuning HID kit Problem

So i ordered a DDM Tuning Kit, installed it, and everything worked. The next day i turned on my bike and the low beam flickered on and right back off. The High beam still works. I was curious if anyone else had this problem. I have a 2009 zx10r.

When i called them they said I would need a wiring harness, i just thought it was odd that it worked perfectly for a day and then i go to ride again the next day and it doesnt work.
Chuck84 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-24-2010, 02:02 PM
WSB Rider
 
Join Date: Jun 2009
Location: Bozeman, MT
Posts: 763
Posting Frequency
 
I assume you've already done this, but i would start checking all the plugs, then the power/ground wire going to the bulb. If you have a test light it may save you some time.
Scott10r is offline  
post #3 of 6 Old 03-24-2010, 02:08 PM
WSB Rider
 
KevinF's Avatar
 
Join Date: Jan 2009
Location: Crestview, Florida
Posts: 678
Posting Frequency
   
Might be a bad ballast. I bought a set and my low beam did that all the time. Ordered a new kit from starroters. The ballast looked like it was built alot better and I have never had a problem. The kits take alot of electricity to get warmed up. It would be safe to say that is why your highbeam works because the bike is already cranked and then you switch the switch on. Where as the low beam is coming on while the bike is starting. I had this same problem and the new ballast fixed it
KevinF is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 03-24-2010, 03:23 PM Thread Starter
Squid
 
Join Date: Mar 2010
Posts: 12
Posting Frequency
 
Yea i checked all my fuses. I called in again earlier today and another guy from DDM said it might be a bad ballast... When i get home im going to switch them and see what happens. Just sucks i already hard wired in the high beam.... hope i dont have to pull that crap out just to test it.
Chuck84 is offline  
post #5 of 6 Old 03-24-2010, 03:26 PM
WSB Rider
 
KevinF's Avatar
 
Join Date: Jan 2009
Location: Crestview, Florida
Posts: 678
Posting Frequency
   
I did that like 4 times. Good luck.
KevinF is offline  
post #6 of 6 Old 03-24-2010, 03:40 PM
Squid
 
RDLYN13000's Avatar
 
Join Date: May 2009
Posts: 6,017
Posting Frequency
Images: 38
           
Damn my DDM low beam just went out about an hour ago :( I checked the plugs and its still out, I guess this answers my question as well....
RDLYN13000 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DDM Tuning HID Kits ShinobiZXR Parts, Gear and Accessories 404 02-22-2013 10:43 PM
New h9/h11 HID 6000k DDM Tuning rainking12 Parts, Gear and Accessories 9 06-05-2009 01:07 AM
starrotors or ddm tuning HID? rainking12 The ZX-10R 12 05-26-2009 12:38 PM
06/07 HID Kit from DDM (Raptor) 1mean10 Performance and Tech 6 05-14-2009 01:03 PM
Hid light kit problem jryanfallon The ZX-10R 5 04-29-2009 09:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome