Clutch switch issues - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-03-2010, 05:54 PM Thread Starter
Track Day Rider
 
Coonsy's Avatar
 
Join Date: Aug 2010
Location: Vallejo, CA
Posts: 129
Posting Frequency
 
Clutch switch issues

So, I replaced my old levers with some adjustable shorties, and now I can't start without going into neutral. I tried adjusting the lever all the way out, still won't work, tried un-and-replugging in the connection wires (unhooked it while I was changing the levers), and fully depressing the switch once and then releasing it to see if that worked.

Still nothing, and it worked just fine with the old levers. Yes, this lever has the thingy that activates the switch, and it fully releases when the lever is pulled in. I haven't tried putting the old levers back on to see if they will still work...

Ideas?
Coonsy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-04-2010, 12:52 AM
Bloo Moderator
 
bluedevil's Avatar
 
Join Date: Nov 2004
Location: SAC,CA
Posts: 23,742
Posting Frequency
Images: 3
           
Quote:
Originally Posted by Coonsy View Post
So, I replaced my old levers with some adjustable shorties, and now I can't start without going into neutral. I tried adjusting the lever all the way out, still won't work, tried un-and-replugging in the connection wires (unhooked it while I was changing the levers), and fully depressing the switch once and then releasing it to see if that worked.

Still nothing, and it worked just fine with the old levers. Yes, this lever has the thingy that activates the switch, and it fully releases when the lever is pulled in. I haven't tried putting the old levers back on to see if they will still work...

Ideas?
Please learn the site before posting....we have a Performance and Tech Section and that's where this Thread belongs......I don't think you know when it's fully "RELEASES" there is no click you need to put a flash light and see that the switch pole is not touching....I bet if it's not touching the lever the bike will start in Neutral. Moving to the right Section

bloo
bluedevil is offline  
post #3 of 4 Old 08-04-2010, 12:55 AM
Bloo Moderator
 
bluedevil's Avatar
 
Join Date: Nov 2004
Location: SAC,CA
Posts: 23,742
Posting Frequency
Images: 3
           
Forgot.....you need to post what levers you Installed for help

bloo
bluedevil is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 08-05-2010, 11:00 AM Thread Starter
Track Day Rider
 
Coonsy's Avatar
 
Join Date: Aug 2010
Location: Vallejo, CA
Posts: 129
Posting Frequency
 
Quote:
Originally Posted by bluedevil View Post
Please learn the site before posting....we have a Performance and Tech Section and that's where this Thread belongs......I don't think you know when it's fully "RELEASES" there is no click you need to put a flash light and see that the switch pole is not touching....I bet if it's not touching the lever the bike will start in Neutral. Moving to the right Section

bloo
Um, it doesn't touch, there is a measurable amount of air between the lever peg and the switch pole - probably close to 1/8" when I have the lever fully engaged. That's why I can't figure out what the problem was. Not sure if it's pushing the switch back in far enough (as in do the switches need to reset or something - although that's why I tried fully depressing it myself which didn't make a difference).

I have not tried disassembling the switch yet and cleaning it, but it worked fine before the swap so I would find i hard to believe that is the problem.

As for what levers, they are an aftermarket knock-off similar to CRG in appearance, but meant for street riding (I know, I know, don't buy knock-offs - normally wouldn't but these were from a reputable local supplier and a large number of people locally have tried them with no problems, and the local dealership has a good reputation and mostly only carries name brand items, this is one of the few cheaper options they actually carry). Don't need a dispensation on the evils of knock-off parts, I've heard it before this is probably the only knock-off item I've purchased.
Coonsy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 ZX-10R clutch switch brianhevans The ZX-10R 17 05-05-2009 08:38 AM
'06 Clutch issues Gang Green Performance and Tech 1 08-17-2008 10:05 PM
WTB: Clutch Switch 06-07 Zx10 K7ZX10RGuy Wanted: Buy or Trade 1 07-23-2008 04:08 PM
Clutch issues Killentime Performance and Tech 5 05-19-2007 02:20 PM
Clutch issues GARSZX10R Performance and Tech 55 09-13-2006 11:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome