busa clutch problem - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-16-2007, 12:58 PM Thread Starter
 
Join Date: May 2007
Posts: 15
Posting Frequency
 
busa clutch problem

i know this isn't a busa forum but it is for my buddy. he has a 2001 busa and gone through 4 clutches already this season at the track which started in april. no miles on the street and he has the clutch cush mod in it but it didn't seem to help cause he is still going through them. any ideas as to why he is eating clutches. everything is put in right but this last clutch probably has 25 runs on it and it is slipping bad already. please give feedback
DRAGRACER601 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-16-2007, 01:34 PM
GP Star
 
Ruthless Racing's Avatar
 
Join Date: Jul 2005
Location: Jesup, GA
Posts: 4,049
Posting Frequency
Images: 9
    
Quote:
Originally Posted by DRAGRACER601 View Post
i know this isn't a busa forum but it is for my buddy. he has a 2001 busa and gone through 4 clutches already this season at the track which started in april. no miles on the street and he has the clutch cush mod in it but it didn't seem to help cause he is still going through them. any ideas as to why he is eating clutches. everything is put in right but this last clutch probably has 25 runs on it and it is slipping bad already. please give feedback
Have ya'll put stiffer springs in it? Check the clutch cyclinder to see if it's cracked?? Not really familiar with busa clutch

Kenny Poppell
AMA Dragbike SuperSport #1000
2007 AMA Dragbike 1000SS National Champion
2007 1000SS 1/8th ET Record Holder 5.967
Best 1/[email protected] Best 1/[email protected] Stock Wheelbase
Special Thanks:

Performance Psycle
Richies Tires
http://www.XXXRacingFuel.com
http://www.SuperbikeSpecialties.com
http://www.Tsukigi.com
http://www.CycleConceptsRacing.com
http://www.myspace.com/ruthlessracing1
Ruthless Racing is offline  
post #3 of 7 Old 05-16-2007, 01:39 PM
WSB Rider
 
firemedic1343's Avatar
 
Join Date: Mar 2007
Posts: 736
Posting Frequency
 
Suzuki has a lot of clutch problems...I've heard of a lot of problems with the K5 and K6...even with the new K7.

Sorry, I don't have any good advice, other than try posting this thread to a few more forums(busa guys will give you the best advice).
firemedic1343 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 05-16-2007, 06:39 PM Thread Starter
 
Join Date: May 2007
Posts: 15
Posting Frequency
 
Thanks Guys For Your Help!! You Know Of A Good Forum Where I Could Find Out Or Ask Some People
DRAGRACER601 is offline  
post #5 of 7 Old 05-17-2007, 11:32 AM Thread Starter
 
Join Date: May 2007
Posts: 15
Posting Frequency
 
Is There Anyone That Can Help Me Out With This Problem Or Guide Me In The Right Direction To Get Some Help? Thank You I Appreciate All Your Help
DRAGRACER601 is offline  
post #6 of 7 Old 05-22-2007, 10:39 AM
 
Join Date: May 2007
Posts: 43
Posting Frequency
 
Are you using stock friction plates? If not, I would definetly recommend using the stock plates. Stronger springs might help, but he is probably just slipping the clutch out too long. It doesn't take long to burn up a clutch, especially when you're hot lapping at the track. Gotta let it cool down.
1slow10 is offline  
post #7 of 7 Old 05-22-2007, 10:45 AM
Champion Rider
 
seatec's Avatar
 
Join Date: Feb 2007
Location: Clearwater, FL
Posts: 424
Posting Frequency
Images: 1
 
hayabusa.org
suzukihayabusa.org

~SeaTec
seatec is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Problem appocalypse Performance and Tech 3 09-27-2006 12:05 PM
05' Clutch/transmission problem? rocket10r Performance and Tech 14 03-19-2005 08:09 AM
Clutch problem????? morrisjl2 Performance and Tech 11 02-12-2005 10:40 PM
Clutch Cable wear (potential problem for all 10R owners)! RichTJ99 Performance and Tech 25 01-23-2005 09:19 PM
Clutch problem chicken The ZX-10R 17 04-12-2004 11:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome