Gen 3: 2008-2010 Brake light fuse popps after two minutes of riding - Kawasaki ZX-10R.net
 2Likes
  • 1 Post By SkyDork
  • 1 Post By ddipaola
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-17-2018, 10:12 AM Thread Starter
Squid
 
Join Date: Aug 2018
Posts: 1
Posting Frequency
 
Brake light fuse popps after two minutes of riding

Ok sports, i just baught a gen 3 zx10r and about a week after taking it home the breaklight went out and got pulled over before i realised. I can change the fuse and it will work just fine untill i ride for a bit. Then it poppes randomly....
Any ideas or experiences?
Thanks
jake890394 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-17-2018, 11:03 AM
REPOST Enforcement Mod
 
SkyDork's Avatar
 
Join Date: Feb 2006
Location: Wesley Chapel, FL
Posts: 13,512
Posting Frequency
           
Garage
Welcome.

Yeah, we need a little more info than that. If the fuse pops, then you have an electrical problem. Obviously. The power is shorting to ground and drawing too much amperage through the fuse. That's not typical for that model of bike, so you need to troubleshoot the issue.

Is it the stock OEM taillight in there or has it been replaced to an aftermarket one? Do the turn signals work? Does the license plate light work? Have you unplugged it and checked the connector? Any obvious signs that the wiring is melting is certain spots? Any other issues with the bike?
dudewhrsmybike likes this.

I may not be perfect, but at least I don't ride a Suzuki.

Ridding the Internet of bad grammar, 1 post at a time.
#WordCrimes




SkyDork is offline  
post #3 of 3 Old 08-17-2018, 12:51 PM
WSB Rider
 
ddipaola's Avatar
 
Join Date: Feb 2018
Location: Macomb, MI
Posts: 651
Posting Frequency
 
Garage
Quote:
Originally Posted by jake890394 View Post
Ok sports, i just baught a gen 3 zx10r and about a week after taking it home the breaklight went out and got pulled over before i realised. I can change the fuse and it will work just fine untill i ride for a bit. Then it poppes randomly....
Any ideas or experiences?
Thanks
Did the fuse pop (light discoloration) or blow up (heavy black discoloration)?
michael4012 likes this.

When in doubt... send it!
ddipaola is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Light Fuse Problems!!!! GCE-ZX10R Performance and Tech 0 05-29-2010 08:46 AM
Fuse for parking and brake light? narc300c Performance and Tech 2 04-29-2010 07:54 PM
Question re correct Fuse after HID conversion Esta56 The ZX-10R 6 11-21-2008 04:48 PM
need help!!!blowout the ECU fuse after walbro installed plasticbaby Performance and Tech 18 12-03-2007 12:13 PM
Wrecked my 10 30 minutes ago! Austin10RPowers The ZX-10R 42 02-28-2005 03:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome