Bike FI light is on, checked code - need help figuring which code - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 12-27-2005, 08:17 PM Thread Starter
Track Day Rider
 
SpeedyCorky's Avatar
 
Join Date: Dec 2005
Location: California Bay Area
Posts: 242
Posting Frequency
 
Send a message via AIM to SpeedyCorky
Bike FI light is on, checked code - need help figuring which code

UPDATED: see post below also!

yeah so my FI light is on, and i did the procedure to get the light to blink and check what was wrong. the test worked, but i'm not 100% confident that i'm reading the series of blinks correctly. i have made an AVI video of it, but i dont have anywhere to upload it to... so if someone can host it, then that'd help a lot...

anywayz the bike has a full Arata exaust, PCIII usb and has a custom dyno map. obviously the exaust valve is disconnected from the exaust system. the exaust valve wires are still connected. previous owner said the shop that installed the exaust and dyno tuned the bike, forgot to do some step to turn off the light, and that the previous owner never went back in to the shop to have the light turned off. bike runs great, no problems at all. idles great, increadable power, go dyno results to prove it blah blah blah



the light is basically giving me a code like this:

XX----XX----XX----X-X-X-X REPEATS

with X being when and how long the FI light goes on, and the - being time inbetween.


i think its telling me an exaust valve sensor problem (the exaust valve is compleatly disconnected and removed...and yeah the FI light was on before i disconnected it and removed it).


HELP !!!

Last edited by SpeedyCorky; 12-27-2005 at 08:43 PM.
SpeedyCorky is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-27-2005, 08:32 PM Thread Starter
Track Day Rider
 
SpeedyCorky's Avatar
 
Join Date: Dec 2005
Location: California Bay Area
Posts: 242
Posting Frequency
 
Send a message via AIM to SpeedyCorky
ooooooook update

ok so i plug the exaust valve thing back in, do the check again, light goes off, stays off....

funny - considering the exaust valve wires were always connected before; why was the FI light on?! and why would disconnecting the wires, testing it, reconnecting it, testing it again - cause the light to stay off?


soooooo now the question is - how to i dummy wire it up so the bike computer thinks the exaust valve in plugged in (so that the light doesnt go on), but actually have the big heavy exaust valve thing removed from the bike.....?

Last edited by SpeedyCorky; 12-27-2005 at 08:39 PM.
SpeedyCorky is offline  
post #3 of 7 Old 12-27-2005, 09:16 PM
Still here
 
ZX10Miami's Avatar
 
Join Date: Apr 2005
Location: S.W. Corner of The Bermuda Triangle.
Posts: 9,059
Posting Frequency
Images: 1
           
More to it than than that. I think Bninja fried a computer trying to come up with a cheaper alternative to Ivan's servo eliminator as in the thread linked below.

https://zx-10r.net/forum/showthread.p...rvo+eliminator

and https://zx-10r.net/forum/showthread.p...rvo+eliminator

Sarah Palin and friends can call it a snow machine all they want but Yamaha, Polaris and Bombardier plus the related magazines all seem to call them Snowmobiles.

Snow machines create snow on ski slopes. Just sayin'
ZX10Miami is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 12-27-2005, 10:30 PM
Supercharged Mod
 
Join Date: May 2004
Location: Toronto, Canada
Posts: 4,388
Posting Frequency
         
choice 1: Leave the servo motor in place and electrically connected but with no cables attached to it. This is what most people do. To save the 1 lb of weight, skip lunch.

choice 2: Buy the widget from Ivan that plugs into the wiring harness to allow the servo motor to be eliminated. Don't try to re-invent it.

There could be some cases where a fault code is stored until the codes are deliberately scanned. It happens on OBD-II cars.


Helibars, MRA screen, Ohlins damper, reversed shift pattern, sorted suspension, braided lines, Michelin Pilot Power, all else stock 'coz it's fast enough!
GoFaster is offline  
post #5 of 7 Old 12-28-2005, 12:56 AM Thread Starter
Track Day Rider
 
SpeedyCorky's Avatar
 
Join Date: Dec 2005
Location: California Bay Area
Posts: 242
Posting Frequency
 
Send a message via AIM to SpeedyCorky
yeah thats what i was figuring about it not clearing the code until the code was scanned and 'reconized'

that 1lb is a lot!!!!! hahaha naw, i'm more concirned about the bulkyness of the exaust servo, i got an alarm and PCIII, and want as much room as possible in the tailsection for water or wallet or whatevera

Last edited by SpeedyCorky; 12-28-2005 at 02:50 PM.
SpeedyCorky is offline  
post #6 of 7 Old 12-28-2005, 02:27 PM
GP Rider
 
Join Date: Mar 2005
Location: central iowa
Posts: 1,113
Posting Frequency
 
I used Ivan's eliminator thingy. Works great and frees up some room for a pc or ignition module.

green 10r, Akro EVO 2, Hyperpro rsc, tre, pcIII, Puig DB, K&N, Purvision HIDs, Speedohealer, GONE

08 Ducati Hypermotard S GONE

08 Kawi Concours 14, Area P full sys, PCV, Flies out
speedfreak is offline  
post #7 of 7 Old 12-28-2005, 02:51 PM Thread Starter
Track Day Rider
 
SpeedyCorky's Avatar
 
Join Date: Dec 2005
Location: California Bay Area
Posts: 242
Posting Frequency
 
Send a message via AIM to SpeedyCorky
good to have a review on Ivan's thingie.. $110 price tho , for me i'm gonna have to wait - other, cheaper, more beneficial mods must come before one that simply turns an annoying light off

Last edited by SpeedyCorky; 12-28-2005 at 04:24 PM.
SpeedyCorky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clear Alternatives Integrated Light How-to... El Diablo The ZX-10R 37 04-06-2010 10:41 PM
Clear Alternatives Integrated Light How-to... El Diablo How To... 1 02-25-2005 10:24 AM
Got my new bike yesterday. ZX10 Guy The ZX-10R 19 10-13-2004 10:20 PM
Love my new ZX-10R - 150 mile impression (with pics!) JLove The ZX-10R 26 10-12-2004 01:18 PM
RedElk's ZX10R Ride and Adventure review swft The ZX-10R 11 03-11-2004 01:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome