back firing anyone? - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 07-20-2005, 12:01 PM Thread Starter
GP Rider
 
ballzman's Avatar
 
Join Date: Jul 2005
Location: York, Pa
Posts: 1,086
Posting Frequency
  
back firing anyone?

I'm brand new to the forum so I would like to say hello.
I have an 05 and I am on my 2nd 10R. I purchased my 05 after totalling my 04. Wow what a bike these things are. After I wrecked my 04 I really didn't even consider any other type of bike besides the 10R...it's an automatic decision for me. After getting my new bike broken in I started to notice that it back fires significantly more than my old bike. The most noticable is at higher rpm's when your on and off the gas. Does anyone know if this is normal. I have a Yoshimura slip on and a just installed a PCIII to correct it but it still does it. I should also note that my new bike lacks power that my 04 had. If any one has suggestions I would appreciate any input. I also must say that I did the 600 mile service myself and didn't do anything other than re-torque all my nuts and bolts and change my oil...did I maybe miss something? Thanks again for any input and I look forward to being a member!
ballzman is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 07-20-2005, 12:19 PM
 
Join Date: May 2005
Posts: 168
Posting Frequency
  
Quote:
I have a Yoshimura slip on and a just installed a PCIII to correct it but it still does it.
Sounds like the PCIII was dialed in wrong. Can you double check it?
FukNRekd is offline  
post #3 of 18 Old 07-20-2005, 12:49 PM
GP Rider
 
eric's Avatar
 
Join Date: Jun 2005
Location: Mi
Posts: 1,369
Posting Frequency
Images: 10
  
get a new map.
eric is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old 07-20-2005, 03:33 PM
 
Join Date: Sep 2003
Posts: 157
Posting Frequency
 
I think he said that it was backfiring BEFORE he put the PCIII on, He put the PCIII on in hopes that it would help.
extremelean is offline  
post #5 of 18 Old 07-20-2005, 03:44 PM
GP Star
 
phastone's Avatar
 
Join Date: May 2004
Location: i
Posts: 2,976
Posting Frequency
  
You'll never get rid of all the backfiring, but if you have a lot then a better fuel map would help.
phastone is offline  
post #6 of 18 Old 07-20-2005, 03:54 PM
Ara
LE Post Whore
 
Ara's Avatar
 
Join Date: Jun 2004
Posts: 6,275
Posting Frequency
Images: 2
       
Or you could try some block off plates.
Ara is offline  
post #7 of 18 Old 07-20-2005, 04:59 PM
 
Join Date: May 2005
Posts: 1,196
Posting Frequency
 
Backfiring can also be caused or at least agrivated by air leaking into the exhaust can.
swjohnsey is offline  
post #8 of 18 Old 07-20-2005, 05:01 PM
Ara
LE Post Whore
 
Ara's Avatar
 
Join Date: Jun 2004
Posts: 6,275
Posting Frequency
Images: 2
       
Well, to add to that, if the pair (or KLEEN or w/e Kawi calls them) valves are not blocked off, not only is air leaking into the exhaust, it is being injected!
Ara is offline  
post #9 of 18 Old 07-20-2005, 06:57 PM
GP Rider
 
iroman's Avatar
 
Join Date: Mar 2005
Location: - Tomball, Texas - 2005 ZX-10R
Posts: 1,277
Posting Frequency
   
I had the Kleen system removed and did not install block-off plates and I do not have any backfiring. If you removed the Kleen sys, that should've taken care of the backfire, if you haven't remove it. If already removed, check for leaks.

I also disconnected the butterfly valve, don't think that has anything to do with backfiring, but my bike use to backfire a lot before I got a custom map and did the other things I mention above and it hasn't backfired once since.
iroman is offline  
post #10 of 18 Old 07-21-2005, 12:04 AM
 
Join Date: Apr 2005
Posts: 350
Posting Frequency
 
no backfiing now,,, never did,,,, but we'll see after all my mods this weekend,,, cross your fingers
AtomAnt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZX-10R tail decals back on... El Diablo The ZX-10R 29 05-20-2007 08:19 AM
My bike is back - Pics inside crispin The ZX-10R 63 03-24-2005 11:47 PM
Bring Back Loudon cbrf41999 Race and Stunt 8 01-21-2005 09:57 AM
Back Protectors hillcountry10r The ZX-10R 36 01-06-2005 07:03 AM
RedElk's ZX10R Ride and Adventure review swft The ZX-10R 11 03-11-2004 01:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome