Gen 4: 2011-2015 ABS light - Kawasaki ZX-10R.net
 2Likes
  • 1 Post By Kawasaki Brad
  • 1 Post By Doppler
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-22-2019, 02:03 PM Thread Starter
Squid
 
Jbsmooth's Avatar
 
Join Date: Apr 2018
Posts: 5
Posting Frequency
 
ABS light

Has anybody else had an issue with there ABS light staying on? Ive done the basic trouble shoot batt disconnected, switch different modes, check the wheels for any thing out of place , unplugged.Its a 14 with around 4k .. thanks J.Humph
Jbsmooth is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-22-2019, 03:14 PM
Champion Rider
 
belkins's Avatar
 
Join Date: May 2015
Location: OKC
Posts: 417
Posting Frequency
  
Garage
Quote:
Originally Posted by Jbsmooth View Post
Has anybody else had an issue with there ABS light staying on? Ive done the basic trouble shoot batt disconnected, switch different modes, check the wheels for any thing out of place , unplugged.Its a 14 with around 4k .. thanks J.Humph
I've seen other gen4 do this when the battery is not providing the correct voltage. If that is not the problem then you should be able to pull the code that is triggering the light to stay on.

Also may want to check the fuses.. i believe there is 2 for the abs.

2013 Kawasaki Ninja ZX-10R

~Woolich ECU Flash/Log Box/AutoTune~Driven Block Off Plates~Woodcraft Frame sliders~Cox Radiator Guard~OEM Seat Cowl~Tinted Hotbodies Venom Windscreen~Lightech Chain Adjusters/Axle Sliders/Spools~Sato Rearsets/Race Hooks/Bar Ends/Reservoir Covers~Pazzo Shorty Levers~Engine Ice~Motodynamics Rear Turn Signals~Ohlins TTX MKII Rear Shock~R&G Case Savers~M4 Street Slayer Exhaust~Ohlins Race SCU~-1 +2 520 Driven Sprockets~520 DID Gold Chain~

Last edited by belkins; 01-22-2019 at 03:17 PM.
belkins is offline  
post #3 of 4 Old 01-22-2019, 04:07 PM
Squid
 
Kawasaki Brad's Avatar
 
Join Date: Dec 2016
Location: Meanwhile in Canada.....
Posts: 39
Posting Frequency
 
Garage
+1 on battery. Stock one's are very poor quality. Most of the time this is the issue.

The encoders can get chunks of road debris or insects caught in them. Make sure all the slots are clear.

In rare cases the sensors have been known to come loose. Retorque the bolt that holds them on. Better still is to remove the bolt, apply loctite, and retorque.
michael4012 likes this.
Kawasaki Brad is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-22-2019, 07:49 PM
Track Day Rider
 
Doppler's Avatar
 
Join Date: Oct 2015
Location: Australia
Posts: 152
Posting Frequency
 
Garage
Quote:
Originally Posted by belkins View Post
I've seen other gen4 do this when the battery is not providing the correct voltage. If that is not the problem then you should be able to pull the code that is triggering the light to stay on
Quote:
Originally Posted by Kawasaki Brad View Post
+1 on battery. Stock one's are very poor quality. Most of the time this is the issue.
What these guys said. More specifically, it's likely to be the steering damper warning that shows first rather than the ABS (Same light but has ESD or similar in the LCD next to it.)
Kawasaki Brad likes this.

-Woolich/Race Tools/Log Box V3|-Graves Titanium/Carbon cat eliminator|-Ohlins Mechatronic|+2 rear|More stuff + stone chips & bugs
Doppler is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen 4: ABS vs Non-ABS KAWI KILBURN The ZX-10R 56 05-10-2014 06:18 PM
2011 How to tell from ABS n non ABS rider4life The ZX-10R 22 11-17-2011 10:17 PM
Gen 4: Abs or no abs? saigono1 The ZX-10R 7 09-22-2011 06:16 AM
2011 ABS or No ABS? The Nam3less The ZX-10R 71 01-21-2011 08:26 AM
2011 zx10r abs and no abs here comerbc5 Welcome Newbies! 1 11-23-2010 03:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome