636 TPS throttle bodies question - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-25-2010, 07:11 PM Thread Starter
Squid
 
vamafia46's Avatar
 
Join Date: May 2009
Location: Birmingham
Posts: 43
Posting Frequency
 
636 TPS throttle bodies question

My 06 636 track bike wont start. I had a 06 636 before this one that I currently have and it wouldnt start one day and i found out that there was a problem with the throttle bodies. It was still under waranty so my local dealer installed a new set. Now my track bike wont start and i have the same problem. I did a little bit of research and from what i can tell my TPS is more than likely bad. I was wondering if anyone has heard of this and if you can just install a new TPS rather than a whole new set of throttle bodies? It would be a difference of about a thousand dollars.
vamafia46 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen 1 throttle bodies. 880turbo The ZX-10R 1 02-19-2010 01:40 AM
Throttle Cables, Remove Throttle Bodies? T_Bone The ZX-10R 8 07-09-2009 06:25 PM
Throttle Bodies zx10resky Performance and Tech 0 03-25-2008 03:06 PM
06-07 Throttle Bodies rated zx Parts, Gear and Accessories 2 01-23-2008 03:04 AM
Throttle Bodies speed4life Performance and Tech 10 05-12-2006 11:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome