2011 retainers fit gen 1 - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-02-2011, 10:29 AM Thread Starter
Champion Rider
 
Join Date: Apr 2006
Location: Boynton Bch
Posts: 475
Posting Frequency
 
2011 retainers fit gen 1

i need a set of retainers that wont crack and im trying to save a few bucks by trying to stay away from ti ones.i know garth said they would work but i just want to verify w him or anyboby else who may know for sure.i ask bec someone posted that the gen 3 were diffrent? help im dying to ride!!!
inginekilla is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted: Ti retainers and springs for gen1 bodymanruss518 Wanted: Buy or Trade 0 04-11-2011 12:20 PM
Gen 3: Ti Retainers available? tasos Performance and Tech 4 04-05-2011 08:48 AM
Are the 04-05 or 06/07 retainers better fungames43232 The ZX-10R 49 12-06-2009 01:49 PM
Retainers garth285 Performance and Tech 0 10-30-2009 02:29 PM
zx10 retainers question bodyglove Performance and Tech 42 05-28-2009 08:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome