07 zx10 oil symbol and red light blinking - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 05-17-2013, 10:28 PM Thread Starter
Squid
 
Join Date: May 2013
Posts: 25
Posting Frequency
 
07 zx10 oil symbol and red light blinking

Hey there guys, new to the forum not sure if this post is in the right section, so somebody correct me if im wrong. anyways.
just got my 07 zx10 candy plasma blue today from a dealer today and was fully serviced and including oil change, but my question is that when the key is in "on" mode the oil symbol and red light blink continuously, but when i start the bike the blinking red light stops as well as oil symbol. I checked oil level and its perfect..anyone help me out?
bostonstrong is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-17-2013, 11:05 PM
BigCat for Prez!
 
BigCat10R's Avatar
 
Join Date: Apr 2010
Location: Baton Rouge, Louisiana
Posts: 7,229
Posting Frequency
           
Thats normal man

Sent from Motorcycle.com App


Quote:
Originally Posted by nakedinseattle View Post
in reference to the man card issue, let me clarify it for everyone, " If a man builds a 1000 bridges and sucks one cock, that doesnt make him a bridge builder, it makes him a cock sucker..."
My bike is the fattest and slowest of all the G2s
BigCat10R is offline  
post #3 of 5 Old 05-18-2013, 04:45 AM
WSB Rider
 
Nutter34's Avatar
 
Join Date: May 2007
Location: Nelson, New Zealand
Posts: 971
Posting Frequency
   
To expand a little...

When the engine isn't running, there is no oil pressure, which would result in the light being on.

Once running, the oil pump is delivering pressure, hence the light being out.

If you have any issues in the lubrication system while it's running and the light comes on, that's a good time to kill the motor and figure out why it's come on...

"You are only young once, but you can stay immature indefinitely."
Nutter34 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 05-18-2013, 07:26 AM
Champion Rider
 
eklikewhoa's Avatar
 
Join Date: Mar 2013
Location: Houston, TX
Posts: 291
Posting Frequency
 
My plasma blue does the same thing!

J/K. LoL

Sent from Motorcycle.com Free App
eklikewhoa is offline  
post #5 of 5 Old 05-18-2013, 07:58 AM
REPOST Enforcement Mod
 
SkyDork's Avatar
 
Join Date: Feb 2006
Location: Wesley Chapel, FL
Posts: 13,532
Posting Frequency
           
Garage
Owners manual



Sent from Motorcycle.com Free App

I may not be perfect, but at least I don't ride a Suzuki.

Ridding the Internet of bad grammar, 1 post at a time.
#WordCrimes




SkyDork is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it a dead battery? or what red light flashing oil symbol djr33 The ZX-10R 21 09-03-2014 05:48 AM
Blinking red light after crash Anze The ZX-10R 7 11-05-2011 01:48 PM
Blinking red light Zx10r chris Performance and Tech 14 07-06-2011 08:36 PM
2009 ZX10 Low Oil Warning Light Blinking after oil change 2009ZXLowOilWarning The ZX-10R 18 12-09-2010 08:26 AM
red oil light blinking 10R-rugger Performance and Tech 8 02-09-2008 02:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome