2001 Raptor 660 - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-12-2006, 08:53 PM Thread Starter
I'm here WAY too much..
 
Bullshark's Avatar
 
Join Date: Apr 2006
Location: Long Island, NY
Posts: 1,998
Posting Frequency
Images: 3
     
2001 Raptor 660

Maybe some of you more experienced mechanics can help..

I have a '01 Raptor 660 that I just did the clutch on... I've never done one on a quad before, so I'm not sure if this is normal. I had trouble getting the pull rod to engage with the arm that connects the clutch cable to the case, so I took the screw out, pulled the arm out and finally got it to engage. My problem is that the clutch cable is at near max adjustment and its SO stiff=. It also seems to stay slightly engaged with the lever pulled in. I can put it in neutral and push it like it was nothing, i put it in gear, pull the clutch in and roll it, but it takes much more pushing to get it moving. Its easy to tell that its not completely disengaged. I cant start it b/c I still have the carbs, air box, and sub frame apart. Can I attribute the stiffness to the new springs? Am I missing something? Any suggestions appreciated..
Bullshark is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-12-2006, 09:13 PM
Track Day Rider
 
Join Date: Aug 2006
Location: Monmouth, OR
Posts: 106
Posting Frequency
 
Send a message via AIM to Bigtuna660
I have an 04 Raptor, and while I have not yet replaced the clutch, I do know that my clutch stays partially engaged when pulled in. And when starting in gear, it lurches just a bit sometimes. I know this probably doesn't help, but if you go to ATVconnection.com and go to the Yamaha forum. Those guys know their stuff.

-Brandon

06 ZX-10R
04 Raptor 660
98 CR250

"A wise man never plays leapfrog with a unicorn."
Bigtuna660 is offline  
post #3 of 4 Old 10-12-2006, 09:19 PM
Champion Rider
 
Daves Cycles's Avatar
 
Join Date: Sep 2005
Location: Illinios
Posts: 474
Posting Frequency
    
http://www.rochestermotorsports.com/...ion_detail.asp pull up the clutch page on this unit

You more than likely have the push rod(15) installed wrong.Take the cable off at the pivot arm on the engine.Rotate it till you feel the push rod has made contact with the pressure plate(toward the cable).Take the bolt out that holds the clutch arm from coming out.Pull the rod out rotate it back(away from cable)about a inch then drop it back in.

05 green ZX10R,Akrappovic Evo 2 Carbon w/ hex shorty can full exhaust system,Power Commander USB,Radial front master cylinder(636),Goodridge front and rear carboline brake lines,07 CBR1000RR front brake calipers,Vesrah race front brake pads,Targa tail kit,flush mount front signals,Cabon fiber led rear signals,Ohlins steering dampers,-1 front,Speedo Healer, Pilot Power tires,Gipro Tre and gold Sato's rearsets.

Last edited by Daves Cycles; 10-12-2006 at 09:28 PM.
Daves Cycles is offline  
post #4 of 4 Old 10-12-2006, 09:33 PM
Champion Rider
 
Daves Cycles's Avatar
 
Join Date: Sep 2005
Location: Illinios
Posts: 474
Posting Frequency
    
Quote:
Originally Posted by Bigtuna660
I have an 04 Raptor, and while I have not yet replaced the clutch, I do know that my clutch stays partially engaged when pulled in. And when starting in gear, it lurches just a bit sometimes. I know this probably doesn't help, but if you go to ATVconnection.com and go to the Yamaha forum. Those guys know their stuff.

-Brandon
You might a worn clutch basket.The fingers in the basket get notched from the friction plates.There by not allowing them to release when you pull in the clutch lever.

05 green ZX10R,Akrappovic Evo 2 Carbon w/ hex shorty can full exhaust system,Power Commander USB,Radial front master cylinder(636),Goodridge front and rear carboline brake lines,07 CBR1000RR front brake calipers,Vesrah race front brake pads,Targa tail kit,flush mount front signals,Cabon fiber led rear signals,Ohlins steering dampers,-1 front,Speedo Healer, Pilot Power tires,Gipro Tre and gold Sato's rearsets.
Daves Cycles is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jaws Of Life On A F-22 Raptor !!!! oneradten The Out House 8 01-24-2007 06:59 PM
Raptor shift light help max-out Performance and Tech 9 09-16-2005 08:11 AM
Need help w/ Raptor Shift Light crispin Performance and Tech 18 05-25-2005 04:15 PM
How do I install a Raptor Shift Light? crispin Performance and Tech 18 05-05-2005 12:15 PM
2004 Yamaha Raptor for sale Krazy1 Parts, Gear and Accessories 7 06-30-2004 10:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome