Gen 3: 2008-2010 Stutter/Cutting out around 8k-9k - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-25-2018, 12:45 AM Thread Starter
Squid
 
AARONCARTER's Avatar
 
Join Date: Jun 2018
Posts: 26
Posting Frequency
 
Stutter/Cutting out around 8k-9k

Hi guys, new to the forum!
I have a 2009 Zx10 with 9500 miles
The previous owner left the bike in storage for several years with some fuel in the tank so when I bought it the inside of the tank was completely rusted up and I for obvious reasons assumed it was all in the fuel system. I recently replaced the fuel tank with a great condition used tank, replaced the fuel pump with a low mileage oem pump, was going to just replace all 8 injectors but the guy I bought the parts from sent me an entire throttle body assembly complete with injectors and lines + the 4 secondaries. All of this has been installed along with a new air filter and 4 new spark plugs but low and behold the exact same problem is still present. I have double and triple checked the common problem of having a pinched fuel line as well as jumping the kickstand switch and neither seem to be the culprit.
To explain the problem with a little more detail, The bike seems to run great under 8kish rpm, under load, WOT, cruising etc. but right around that rpm when under load it starts to stutter and cut out really hard, under WOT at that rpm it almost completely dies on itself. I can play with the throttle around those rpm and get it to rise to around 10k or so but not much more. It’s got me stumped, any advise would be much appreciated! Thanks in advance!
AARONCARTER is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
05' zx10r falling on its face around 8k ?? HELP Jeradcarty The ZX-10R 21 06-14-2018 10:47 PM
Gen 4: Rough Idle, Low Speed Stutter, Hesitation around 3K RPM lenshead The ZX-10R 4 11-12-2017 07:09 PM
Gen 2: Ignition cut in 2nd gear around 9k rpms. what could it be? Mr.Flipflops The ZX-10R 4 07-24-2012 05:27 AM
Sub 3000rpm Stutter and rough idle scott22neale The ZX-10R 61 06-19-2012 05:33 PM
08 zx10r high rpm rev stutter snowy10r Performance and Tech 1 05-24-2010 03:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome