02 sensor??!!?? - Kawasaki ZX-10R.net
 1Likes
  • 1 Post By Guarf
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-12-2019, 09:08 PM Thread Starter
Squid
 
Acezx10r's Avatar
 
Join Date: Jul 2019
Posts: 8
Posting Frequency
 
02 sensor??!!??

I just bought full exhaust for my 2010 zx10r I took the stock exhaust off but there was no 02 sensor in it anywhere?
Acezx10r is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-13-2019, 12:24 AM
GP Rider
 
michael4012's Avatar
 
Join Date: Dec 2014
Location: England
Posts: 1,173
Posting Frequency
 
If it was the stock exhaust then the lambdas will have been removed, are there bungs where the lambdas were? under the tank are there plugs with the lambdas removed, and your ECU must of been flashed? Can you post pictures of the system?
michael4012 is offline  
post #3 of 8 Old 08-13-2019, 12:46 AM
Squid
 
Join Date: Jul 2019
Posts: 18
Posting Frequency
 
if the origin of the bike is from the United States, it may not come with o2 sensor
Kawasaki Brad likes this.
Guarf is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 08-13-2019, 12:43 PM
Track Day Rider
 
Twistedsocal13's Avatar
 
Join Date: Feb 2016
Location: OC SoCal
Posts: 211
Posting Frequency
Images: 1
 
Garage
Quote:
Originally Posted by Enrique Leib View Post
if the origin of the bike is from the United States, it may not come with o2 sensor
I know that the first gen didn't or at least mine didn't but thought after that they all had the O2 sensor. Could be wrong
Twistedsocal13 is offline  
post #5 of 8 Old 08-13-2019, 01:47 PM
Squid
 
Kawasaki Brad's Avatar
 
Join Date: Dec 2016
Location: Stony Plain (West of Edmonton, Alberta, Canada)
Posts: 36
Posting Frequency
 
Garage
First Canadian model to get an 02 was the 2016. US and CAN models are usually the same.

Anything can kill you. Pick something fun.
Kawasaki Brad is offline  
post #6 of 8 Old 08-13-2019, 06:40 PM Thread Starter
Squid
 
Acezx10r's Avatar
 
Join Date: Jul 2019
Posts: 8
Posting Frequency
 
..
Attached Thumbnails
Click image for larger version

Name:	20190813_182815_1565739595434.jpg
Views:	10
Size:	80.6 KB
ID:	423787   Click image for larger version

Name:	20190813_182804_1565739617013.jpg
Views:	10
Size:	93.7 KB
ID:	423789  
Acezx10r is offline  
post #7 of 8 Old 08-13-2019, 06:57 PM
GP Rider
 
michael4012's Avatar
 
Join Date: Dec 2014
Location: England
Posts: 1,173
Posting Frequency
 
Well that's a stock system alright, with no O2's, so must be as mentioned not fitted on that model.
michael4012 is offline  
post #8 of 8 Old 08-16-2019, 10:49 AM
Squid
 
Join Date: Dec 2018
Location: Gig Harbor, WA
Posts: 3
Posting Frequency
 
Garage
There are no O2 sensors on the US model for this generation. I have a 2008 and it is the same as yours. There are several aftermarket systems that you can add a O2 sensor if you wish.
tisleeper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome