Kawasaki ZX-10R.net - View Single Post - Gen 5: 2016- Help w/codes and Power Commander V
Thread: Gen 5: 2016- Help w/codes and Power Commander V
View Single Post
post #7 of Old 05-18-2019, 05:21 AM Thread Starter
katsubucket
Squid
 
Join Date: May 2019
Location: New England, USA
Posts: 5
Posting Frequency
 
I pulled the harness out of the ECU and checked all of those cables to make sure I didn't pull one of those pins out while messing with the positap. They all looked good, and the harness felt secure when I went to unplug it, but I took care to be sure it was definitely seated properly when plugging it back in. I also took another look at the positap while I had that harness off, and the connection does look pretty secure, I'm pretty sure there's plenty of contact there .

I tossed the battery on a charger and the voltage is good, the ground was one of the first things that I checked but I pulled the tank and looked at it again also. Looked good. I also had checked the fuses previously, but gave that another look as well for certainty, all was well there.

I ended up reloading the firmware update on the PCV and got the bike to fire, but continue to throw codes. The firmware had been updated prior to the install, but I guess there could have been some small glitch that prevented it from loading correctly. There was a lot of lines in the log after the update that I don't recall seeing when I had done it the first time. Stuff like "initialing", "loading", "100% complete". etc. I'm pretty sure it didn't spit all that information out last time and just gave a generic "update complete" on the bottom of the software. I'm not exactly sure what the issue was, but I literally touched nothing and all of a sudden the bike fired.

The bike at idle seemed to be running perfectly fine, but the codes persist. I gave that guy I had mentioned earlier at the Kawasaki dealer/Dyno tuning facility another call and went over the things I had done since I had talked to him the first time and the results. He also stated that he din't think it was a PCV issue and brought something to my attention I hadn't previously considered. He said that if I turned the key on even once at any point during of after the installation, or while troubleshooting with just one of those sockets not secured and the bike threw codes they would be stored in the ECU and would need to be cleared to go away. Apparently correcting the issue isn't good enough for the ECU, once it's stored that's it, it's in there until it gets cleared electronically. Now that I'm thinking about it I think there's a pretty solid chance that happened considering the number of times I messed around with it. He also suggested that one of the pins in a connector on the PCV itself may not have been seated properly from the factory, apparently that happens with some degree of regularity, now I didn't notice that to be the case but I figure I also could have pulled one out just enough to not make a connection, especially on the lower injectors, a couple were a bit difficult to get to. Or maybe one of them really wasn't seated properly and the second or third time around I inadvertently seated it while plugging it in/messing around with it.

I'm going to take a run down to the dealer this morning and have the clear the codes and see what comes back on, I'm hoping that only the codes(s) related to the exhaust servo come back and I'll be good. I have a jumper for that on it's way but I don't think it'll be here today.

Although I don't have a clear cut cause I'm thinking it was a bad load on the firmware. If the firmware update failed and I plugged in the PCV I think that would basically have the same result as trying to start the bike/turning the key on without any of the plugs the PCV integrates with plugged in, which would also explain why I threw so many codes. It is a ridiculous amount of codes! My jaw dropped when I saw it for the first time. I also tried those YT "clear your error code" methods again now that the bike is running, they still don't work for me.
katsubucket is offline  
 
 
For the best viewing experience please update your browser to Google Chrome