What did you do to your bike today? - Page 5 - Kawasaki ZX-10R.net
 466Likes
 
LinkBack Thread Tools Display Modes
post #41 of 5832 Old 04-01-2011, 07:00 AM Thread Starter
WSB Rider
 
DRFLGD's Avatar
 
Join Date: Mar 2011
Location: Howell,MI
Posts: 662
Posting Frequency
  
Installed the slip-ons on my wifes R6 and my ZX10 and we went for a short ride!
DRFLGD is offline  
Sponsored Links
Advertisement
 
post #42 of 5832 Old 04-01-2011, 03:07 PM
Servo's Eliminatus ;)
 
hellsrazor's Avatar
 
Join Date: Jul 2008
Location: Gulf Coast of Mississippi
Posts: 6,787
Posting Frequency
Images: 23
           
I bought some ZX14 Nissin Calipers and a Radial master cylinder, GPR v4,
a Vortex hanger, and a Hotbodies Undertail and a new Integrated tail light,
-1 up front, +2 Supersprox, Gold chain, EBC HH Sintered Pads, Q2's

In the near future, some s/s brake lines, shorty levers, and hopefully
a A&A supercharger.


What have you done lately???
hellsrazor is offline  
post #43 of 5832 Old 04-01-2011, 03:30 PM
Champion Rider
 
Join Date: Mar 2011
Posts: 338
Posting Frequency
 
Just installed 8000K HIDs!!! couldn't be more pumped!!
04-ZX-10r is offline  
 
post #44 of 5832 Old 04-01-2011, 04:10 PM
Starbucks Connoisseur
 
Static IP's Avatar
 
Join Date: Feb 2006
Location: Beverly Hills
Posts: 4,368
Posting Frequency
           
Still went to the same place and ordred the same thing and drank the same thing.. .Again.

Looks like this might be a repititous situation.

09' Ice Blended Peppermint Mocha Frappuccino
10' Venti Mocha Latte spilled some of it, was too hot
11' Peppermint Mocha W/Extra Shot of Espresso
12' Eggnog Venti Latte
13' Bagel
14' Standard Drip (since a Venti latte went up 20 cents)


Static IP is offline  
post #45 of 5832 Old 04-01-2011, 04:41 PM
WSB Rider
 
BratNetwork's Avatar
 
Join Date: Aug 2008
Location: Haledon, NJ
Posts: 874
Posting Frequency
 
Sat and waited for UPS to bring my shock that was build wrong for my bike just for it not to show today... Very unhappy with the customer service with Traxxion Dynamics - Going on 4 weeks now to get a hose longer hose installed for the remote reservoir...

2008 ZX-10R | Black | Arrow Headers | AreaP Slip-on CF | K&N Filter |GUTS ECU Flash By Guhl Motors | Block-Off Plates | Fender Eliminator | Clear Alternatives Integrated Taillight | Rifleman's 1/5th Throttle Insert | Speedohealer | Pro-Grip 719s | Vortex Bar Ends | Puig Z DB Windscreen | CBR1000 Mirrors | Vortex 520 Sprockets -1/+1 | RK Gold 520 Chain | Galfer SS Lines | Pazzo Shorty Levers | Vortex Gas Cap | Rebuilt Damper | Lightech Rearsets | Much More To Come
BratNetwork is offline  
post #46 of 5832 Old 04-01-2011, 05:27 PM
Squid
 
bigtyme's Avatar
 
Join Date: Jul 2008
Posts: 15
Posting Frequency
 
Smile

Installed Ohlins shock.
bigtyme is offline  
post #47 of 5832 Old 04-01-2011, 05:27 PM
GP Rider
 
MUSHU's Avatar
 
Join Date: Oct 2010
Location: Sun Valley, CA
Posts: 1,727
Posting Frequency
       
Quote:
Originally Posted by Quick10 View Post
Rode it to work! It was 57 this morning and will be 90 for the high
and i just spent more money to add to my beast!
MUSHU is offline  
post #48 of 5832 Old 04-01-2011, 06:57 PM
WSB Rider
 
nfranke's Avatar
 
Join Date: Apr 2010
Location: Westport, Indiana
Posts: 968
Posting Frequency
     
Got parts today, got my 6k hids on and speedo healer on
nfranke is offline  
post #49 of 5832 Old 04-01-2011, 07:24 PM
Champion Rider
 
airforceone's Avatar
 
Join Date: Jan 2011
Location: Queens NY
Posts: 332
Posting Frequency
 
Installed red running lights, frame sliders, solo seat cowl, 8000k hids,brake resevouir sock and got laughed at by my wife for buying full leathers living here in NYC

People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf

R.I.P. Andy Galatas.....Always remembered....Never forgotten...Now riding on in a better place...8 Mar 2011
airforceone is offline  
post #50 of 5832 Old 04-01-2011, 07:24 PM
Track Day Rider
 
SoRicey's Avatar
 
Join Date: Jun 2010
Location: Eagle River, Alaska
Posts: 182
Posting Frequency
Images: 2
 
Tried starting it + fail
SoRicey is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome