Oil filter for the 2016 - Page 4 - Kawasaki ZX-10R.net
 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 53 Old 04-28-2016, 07:50 PM
WSB Rider
 
turtle1000's Avatar
 
Join Date: Oct 2014
Posts: 956
Posting Frequency
 
Anybody checked if the ol wedge the filter with pipe clamp trick works on new bike?

More cowbell
turtle1000 is offline  
Sponsored Links
Advertisement
 
post #32 of 53 Old 04-28-2016, 08:40 PM
tdh
GP Rider
 
tdh's Avatar
 
Join Date: Jan 2015
Posts: 1,528
Posting Frequency
 
Quote:
Originally Posted by Animal11 View Post
Between myself, dricked, at least one more AFMer, and Kyle Wyman that's 4 events too many for me. Oil leaks are too f-ing scary for me.
I didn't realize all of you guys had issues with them. You all had leaks? First I heard about it was just today.

.
tdh is online now  
post #33 of 53 Old 04-28-2016, 08:44 PM
GP Star
 
dricked's Avatar
 
Join Date: Sep 2013
Location: Ontario Canada
Posts: 2,144
Posting Frequency
 
Quote:
Originally Posted by tdh View Post
I didn't realize all of you guys had issues with them. You all had leaks? First I heard about it was just today.
More like a catastrophic failure. About 1/4" of the O-ring blew out while I was going down the straight and when I went to tip the bike in the ass end tried to pass me. I kept it upright it the next rider behind me wasn't so lucky. Haven't used anything but oem since.
dricked is offline  
 
post #34 of 53 Old 04-28-2016, 08:59 PM
tdh
GP Rider
 
tdh's Avatar
 
Join Date: Jan 2015
Posts: 1,528
Posting Frequency
 
Well shit, and I have a stack of 4 or 5 of them. :) I also have a couple of the Frams left. I guess I could stick one of those on until I can get some OEM filters.

.
tdh is online now  
post #35 of 53 Old 04-28-2016, 09:09 PM
Always On Mod
 
Animal11's Avatar
 
Join Date: Jun 2011
Location: Nor-Cal
Posts: 1,829
Posting Frequency
      
Quote:
Originally Posted by tdh View Post
I didn't realize all of you guys had issues with them. You all had leaks? First I heard about it was just today.
Mine had just started to weep a little. I feel very lucky.




Quote:
Originally Posted by tdh View Post
Well shit, and I have a stack of 4 or 5 of them. :) I also have a couple of the Frams left. I guess I could stick one of those on until I can get some OEM filters.
Sadly I've heard frams had a big issue with bad threads and filters becoming projectiles. That was awhile ago from the accounts I heard.

Fast parts, Great Service: PM Mike at Rider's Discount
Animal11 is offline  
post #36 of 53 Old 04-28-2016, 09:20 PM
tdh
GP Rider
 
tdh's Avatar
 
Join Date: Jan 2015
Posts: 1,528
Posting Frequency
 
Weird, I've never had any issues with any of them on any of my bikes. You always have to wonder if it's something with the way they were installed, but hearing you guys have had issues makes me realize there is more to it. I'll call my dealer in the morning and see if I can get a few filters. A buddy will be over picking up his new 2016 ZX10R tomorrow afternoon so I'll have him pick them up for me. I hope they have them in stock. :)

.
tdh is online now  
post #37 of 53 Old 04-29-2016, 09:31 AM
WSB Rider
 
GlassAnkles's Avatar
 
Join Date: May 2013
Location: KS
Posts: 936
Posting Frequency
  
K&N changed manufacturers to increase profits and decrease quality. Id stick with the Hiflo Race version when they come out for the new gen.
GlassAnkles is offline  
post #38 of 53 Old 04-29-2016, 11:24 AM
tdh
GP Rider
 
tdh's Avatar
 
Join Date: Jan 2015
Posts: 1,528
Posting Frequency
 
Just ordered 4 OEM filters.

.
tdh is online now  
post #39 of 53 Old 04-29-2016, 11:25 AM Thread Starter
WSB Rider
 
g-man's Avatar
 
Join Date: Jan 2016
Location: Northern VA
Posts: 588
Posting Frequency
 
Garage
Quote:
Originally Posted by tdh View Post
Just ordered 4 OEM filters.
I'm with you. Not worth saving a few bucks and risking a 15k bike...
g-man is offline  
post #40 of 53 Old 04-29-2016, 11:29 AM
tdh
GP Rider
 
tdh's Avatar
 
Join Date: Jan 2015
Posts: 1,528
Posting Frequency
 
Actually with my racer support discount they're actually cheaper. :)

.
tdh is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome