Gen 1: 2004-2005 clicking sound on acceleration - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-14-2018, 09:34 PM Thread Starter
Squid
 
king8703's Avatar
 
Join Date: Apr 2018
Location: temecula ca
Posts: 8
Posting Frequency
 
Garage
Send a message via AIM to king8703 Send a message via Yahoo to king8703
clicking sound on acceleration

hey guys so i recently changed out my clutch lever after changing it i went for a test ride and then when i went to accelerate hard and feel a jerking and heard the clicking sound any ideas
king8703 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-15-2018, 09:56 AM
GP Star
 
zx racer's Avatar
 
Join Date: Feb 2010
Location: Scottsboro, AL
Posts: 3,690
Posting Frequency
      
Check make sure you have the clutch cable adjusted correct and not binding up.

Sent from my SCH-I545 using Tapatalk

05 ZX-10R SWB.
zx racer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome