fitting gen 2 dash instruments to gen 1 ZX10R - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 21 Old 02-27-2009, 06:24 PM Thread Starter
Squid
 
Join Date: Jan 2009
Location: Hong Kong
Posts: 17
Posting Frequency
Images: 1
 
fitting gen 2 dash instruments to gen 1 ZX10R

Hi Folks,

I have an '05 model ZX-10R but hate the weirdo LCD tachometer. I'd like to replace that with the instrument cluster from the 2nd gen '06 model bike.

Checking the service manuals shows that the wiring is reasonably similar - the only difference I can see is that the g2 bike has a single wire for oil pressure + FI warning - but I hear rumors that the later model bike has a very different speedo sensor which would impact the speedo reading...

Has anyone done this swapout successfully ? If so could you please let me know exactly what's required ? Detailed instructions with photos and wiring diagrams would be greatly appreciated.

Thanks !!!

Rob
robby-hk is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 02-28-2009, 12:25 PM
GP Star
 
Dragone's Avatar
 
Join Date: Dec 2003
Location: NV
Posts: 2,427
Posting Frequency
Images: 11
 
That change out was explained in 2006 I think it was. You will find that it is not an easy swap. Do a search for it. Good luck

edit: My only contribution to that topic.....was a frickin scan of the 2nd gen pin layout. Now I need to relook that one up. lol

W.F.O.ing with style will bring life back into focus
Dragone is offline  
post #3 of 21 Old 03-03-2009, 06:02 AM
Yui
Street Rider
 
Yui's Avatar
 
Join Date: May 2005
Posts: 81
Posting Frequency
Images: 12
 
I installed a Z1000 Dashboard on my '05 race bike, the basics are full functionally except the fuel gauge. (I don't have it)
Sorry but I don't need turn lights, chronometer or headlight, and I don't connected this, but I think that will work well.

ZX10R 2005, Kevlar brake hoses, Lowering bones, Intake kit camshaft, Leovince Evo2 full Exhaust, Brembo master brake 19x18, Fiberglass fairing, Brembo M4 Calipers, PVM Wheels, Axis front Rotors.
Yui is offline  
 
post #4 of 21 Old 03-03-2009, 10:20 AM
WSB Rider
 
BornSinner's Avatar
 
Join Date: Feb 2006
Location: Florida
Posts: 840
Posting Frequency
Images: 19
         
Send a message via AIM to BornSinner
I think BlueDevil has done that swap....and very clean look also....

BornSinner is offline  
post #5 of 21 Old 03-03-2009, 04:39 PM
GP Star
 
Dragone's Avatar
 
Join Date: Dec 2003
Location: NV
Posts: 2,427
Posting Frequency
Images: 11
 
Quote:
Originally Posted by BornSinner View Post
I think BlueDevil has done that swap....and very clean look also....
Yes, BlueDevil was the one that instigated the try out and to see if it would work.

W.F.O.ing with style will bring life back into focus
Dragone is offline  
post #6 of 21 Old 03-04-2009, 09:44 AM
Yui
Street Rider
 
Yui's Avatar
 
Join Date: May 2005
Posts: 81
Posting Frequency
Images: 12
 
This is my dash installed
Attached Thumbnails
Click image for larger version

Name:	DSC02975.jpg
Views:	1772
Size:	162.1 KB
ID:	140819  

ZX10R 2005, Kevlar brake hoses, Lowering bones, Intake kit camshaft, Leovince Evo2 full Exhaust, Brembo master brake 19x18, Fiberglass fairing, Brembo M4 Calipers, PVM Wheels, Axis front Rotors.
Yui is offline  
post #7 of 21 Old 05-15-2009, 08:20 PM Thread Starter
Squid
 
Join Date: Jan 2009
Location: Hong Kong
Posts: 17
Posting Frequency
Images: 1
 
Done !!!!

Thanks to all for the help.

the overall process was :

1. source new gauge - I used Ebay

2. open gauge, de-solder new cluster's female connector block

3. source Acumen DG8 wiring loom - cut off most of it but retain female connector for 04/05 model wiring harness + tail cables.

4. solder tail cables into the slots vacated by the 06/07 connector. Note wiring is similar but not entirely the same as the older model. Check manuals for details. Or PM me, I have the pinouts

5. cross-connect the cluster's 12v power input to the to the gen1 bike's speed sensor power wire - the gen2 cluster doesn't supply this

6. source & setup Speedo Healer v4 to compensate for the 7.4x difference in speedo sensor pulses between Gen1 & Gen 2 bikes.

7. Enjoy
robby-hk is offline  
post #8 of 21 Old 05-16-2009, 04:02 AM
GP Star
 
mr747's Avatar
 
Join Date: Nov 2008
Location: melbourne Australia
Posts: 2,355
Posting Frequency
  
you got pics please show me


FULLY LOADED :)
mr747 is offline  
post #9 of 21 Old 05-16-2009, 09:22 AM Thread Starter
Squid
 
Join Date: Jan 2009
Location: Hong Kong
Posts: 17
Posting Frequency
Images: 1
 
sure but I can't seem to get them to upload to the forum ? it keeps giving me an error message, or timing out or something. Is there a file size limit ?

either way I'm happy to share all the info I have, PM me for more details.

Cheers

Rob
robby-hk is offline  
post #10 of 21 Old 05-16-2009, 09:42 AM
GP Star
 
mr747's Avatar
 
Join Date: Nov 2008
Location: melbourne Australia
Posts: 2,355
Posting Frequency
  
do you have a how to??? on this swap


FULLY LOADED :)
mr747 is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome