Common situation - Oil changes "Oil pressure warning lamp" - Kawasaki ZX-10R.net
 1Likes
  • 1 Post By GoFaster
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-09-2010, 08:38 AM Thread Starter
Supercharged Mod
 
Join Date: May 2004
Location: Toronto, Canada
Posts: 4,381
Posting Frequency
         
Common situation - Oil changes "Oil pressure warning lamp"

In the interest of not having repetitive discussions, this thread is to document a not-uncommon situation when changing the oil on 2004 through 2010 model year ZX10R's.

The issue is that if the oil pump is left "dry" on both sides (i.e. you have the filter removed and you have the sump drained at the same time), oil will siphon out of the oil pump, leading to an air-lock and no oil pressure upon restarting the engine. It only happens occasionally.

The situation can be largely avoided by first draining the oil then refilling it, THEN changing the oil filter.

Other suggestions include partially filling the oil filter before re-installing it but I would suggest doing this in addition to doing the oil change first and then the filter change.

If you change the oil and the oil pressure warning lamp remains on (or flashes) for more than 3 seconds after restarting the engine:

1. Turn the engine OFF!

2. Position a drain pan underneath the oil filter.

3. Loosen the oil filter slightly (1 or 2 turns) so that it is slightly clear of the seal.

4. With your finger on the engine-stop switch, crank the engine a couple of revolutions - if it tries to start, stop it immediately.

5. Check whether oil is coming out from under the base of the oil filter - this indicates that the oil pump is now pumping. If it is not, repeat steps 4 and 5.

6. Tighten the oil filter securely.


All existing threads concerning this situation will be locked and all subsequent threads about this situation (which means you failed to read the sticky thread) will be locked.
frank333 likes this.


Helibars, MRA screen, Ohlins damper, reversed shift pattern, sorted suspension, braided lines, Michelin Pilot Power, all else stock 'coz it's fast enough!

Last edited by GoFaster; 12-09-2010 at 08:54 AM.
GoFaster is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome