Clutch pressure rod problem, How frequent? - Page 2 - Kawasaki ZX-10R.net
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 23 Old 01-12-2008, 02:04 PM
WSB Rider
 
redline659's Avatar
 
Join Date: May 2007
Posts: 819
Posting Frequency
  
Will do, I have hit quite a few roadbumps with mine,,, clutch basket rivet snapping off trashing motor #1, basket pin end snapping off,,, pinching ring lands, spinning bearings,, hahahah,,,, The rods are still good though.... Mine gave up at 600 miles heheheheh,,,, Heads up on the 04-05 valve spring retainers, they are cast aluminum,,,,,, JUNK,,,,,
redline659 is offline  
Sponsored Links
Advertisement
 
post #12 of 23 Old 01-14-2008, 05:55 PM Thread Starter
Track Day Rider
 
Join Date: Nov 2006
Posts: 116
Posting Frequency
 
Only 4-5 persons total who had this problem in the past???.
We must be very unlucky !

2005 RAW TITANIUM ZX-10R:
04 /05 Kawasaki race intake cam, 0.45mm head gasket, full titanium akrapovic exhaust, Woolich racing LBP, PCIII USB, BMC race air filter,
wideband O2 sensor, annitori Rl QS, Hyperpro RSC steering damper, Shorai lithium battery, gipro ds gear indicator,
healtech Shift light pro, ZX-14 front caliper

2002 ZX-12R all stock

1993 MUSTANG LX 5.0L, N/A 400 HP, 11.82@116 MPH on 17" E.T. street tire
STEPH93LX is offline  
post #13 of 23 Old 01-14-2008, 11:11 PM
WSB Rider
 
redline659's Avatar
 
Join Date: May 2007
Posts: 819
Posting Frequency
  
Hahah, nope its a well known fact in the drag racing world
redline659 is offline  
 
post #14 of 23 Old 01-14-2008, 11:12 PM
WSB Rider
 
redline659's Avatar
 
Join Date: May 2007
Posts: 819
Posting Frequency
  
when you start throwing big clutch springs in them,,,, the end will actually just snap off,,,,,, isnt that nice
redline659 is offline  
post #15 of 23 Old 01-14-2008, 11:57 PM
WSB Rider
 
RussMcB's Avatar
 
Join Date: Jan 2007
Location: Marietta, GA USA
Posts: 664
Posting Frequency
Images: 1
 
I tried to be liberal with anti seize when I assembled mine, but I'm crossing my fingers it wont break off. I have stiffer clutch springs. I'm an interested buyer if new and improved parts are available.

RussMcB
F1000 (SCCA Formula Car w/ '07 ZX-10R engine) - Sold in 2010 :-(
'99 ZRX1100
Marietta, GA USA
RussMcB is offline  
post #16 of 23 Old 01-15-2008, 12:28 AM
Squid
 
1slow10's Avatar
 
Join Date: May 2007
Posts: 43
Posting Frequency
 
This sounds like something fun to look forward to....great LOL.
1slow10 is offline  
post #17 of 23 Old 01-15-2008, 09:18 AM
GP Star
 
maze's Avatar
 
Join Date: Dec 2004
Location: Maryland
Posts: 2,261
Posting Frequency
Images: 4
    
Quote:
Originally Posted by STEPH93LX View Post
What is your mileage and how many time you had to replace those parts since you have your 2004 ?

For the parts you mean I should change the rod, the lever that pull the rod +
the ball bearing.


Thank you for your input!
I had to replace it twice only because the berrings were bad the first time and the new rod got chewed up because of that. After those were replaced than it was all good.

The only thing nessecary for the triumph of evil is for good men to do nothing

"sometimes in order to truly live life you must risk it."

You hit the lights, I hit the gas...


THERE ARE ONLY THREE SPEEDS, FAST, VERY FAST, AND OH SHIT!
maze is offline  
post #18 of 23 Old 01-15-2008, 11:53 AM Thread Starter
Track Day Rider
 
Join Date: Nov 2006
Posts: 116
Posting Frequency
 
Quote:
Originally Posted by maze View Post
I had to replace it twice only because the berrings were bad the first time and the new rod got chewed up because of that. After those were replaced than it was all good.
Good to know. I will certainly change the bearing at the same time.
Thank you!

2005 RAW TITANIUM ZX-10R:
04 /05 Kawasaki race intake cam, 0.45mm head gasket, full titanium akrapovic exhaust, Woolich racing LBP, PCIII USB, BMC race air filter,
wideband O2 sensor, annitori Rl QS, Hyperpro RSC steering damper, Shorai lithium battery, gipro ds gear indicator,
healtech Shift light pro, ZX-14 front caliper

2002 ZX-12R all stock

1993 MUSTANG LX 5.0L, N/A 400 HP, 11.82@116 MPH on 17" E.T. street tire
STEPH93LX is offline  
post #19 of 23 Old 01-15-2008, 12:11 PM
GP Star
 
maze's Avatar
 
Join Date: Dec 2004
Location: Maryland
Posts: 2,261
Posting Frequency
Images: 4
    
As for mileage I don't know off the top of my head from when it happened. I drag race it and so I'm pretty hard on clutch parts. I also have stiffer springs in but only three not 5 cause I was told that that would give me the desired outcome that I was looking for at the time. It works well.

The only thing nessecary for the triumph of evil is for good men to do nothing

"sometimes in order to truly live life you must risk it."

You hit the lights, I hit the gas...


THERE ARE ONLY THREE SPEEDS, FAST, VERY FAST, AND OH SHIT!
maze is offline  
post #20 of 23 Old 01-15-2008, 03:03 PM
WSB Rider
 
redline659's Avatar
 
Join Date: May 2007
Posts: 819
Posting Frequency
  
We were trying to hold in 260 hp with the stock setup so we had in HD springs and shimshahahah and it was still eating clutches but it snapped off along with some other things
redline659 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome