Gen 2: 2006-2007 PC3 Help - Kawasaki ZX-10R.net
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-27-2017, 10:05 PM Thread Starter
Squid
 
Chris_1973's Avatar
 
Join Date: Jul 2016
Location: Calgary
Posts: 35
Posting Frequency
 
PC3 Help

Need a little help with a new to me but used PC3 i just picked up from ebay.

I installed it tonight with the base map. My bike still has the stock exhaust with the cats removed and a K&N filter. I've also disabled the Pair valve. I do plan on a dyno tune next year and i was hoping to get rid of the popping since the cat removal.

Anyway, onto the issue. i installed the PC3 tonight and fired it up. ran odd so i shut it done and tired again. it would not fire. Tired a few times and it just started knocking and grinding but would not fire. When it did finally fire up did gas started pouring out of the vent wholes in the back of the mufflers. Not just a little gas, lots of gas. I shut it right down.

Took off the Power Commander and she fired up great like my baby always does. Gas was still coming out the vent holes but it stopped after a few.

Help please. Any ideas???


On a side note. Anybody else been stupid enough to crack their preload spacer while doing their front springs?? That was yesterdays sh!t show. I need to put tools down for awhile.

Cheers

Chris_1973 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome