05' zx10r falling on its face around 8k ?? HELP - Page 2 - Kawasaki ZX-10R.net
 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 18 Old 10-28-2017, 02:33 PM Thread Starter
Squid
 
Join Date: Oct 2017
Posts: 5
Posting Frequency
 
Ok I found a lil time to troubleshoot and doesn't seem to be missing on any cylinder , temps outta head was relatively close together... So next test was fuel pump, and not sure how to test pressure on it but tested flow rate and according to owners manual it's NB a bit short.. manual says 2.4oz (per 4 sec. Turn of key) and I'm under 2 oz and pressure although not measured seems weak, manual says 44 psi I believe, and mine was basically dribbling into measuring cup.. thinking about replacing pump but would like some suggestions or if this was normal... Thanks again
Jeradcarty is offline  
Sponsored Links
Advertisement
 
post #12 of 18 Old 10-28-2017, 04:12 PM
WSB Rider
 
Victors's Avatar
 
Join Date: Jun 2013
Location: Michigan
Posts: 608
Posting Frequency
 
Garage
Replace it

2013 10R
2007 650R
2016 10R
Victors is offline  
post #13 of 18 Old 10-28-2017, 08:54 PM
GP Star
 
blink.'s Avatar
 
Join Date: Jul 2010
Location: North Carolina
Posts: 2,267
Posting Frequency
           
Spit on your finger to test the HOT exhaust pipes?!? Just spit on the pipe if you're going that route LOL.

It's your fuel pump, like I said it's common.
.

blink. is offline  
 
post #14 of 18 Old 10-29-2017, 02:21 PM
Squid
 
Ghettochilds's Avatar
 
Join Date: Jan 2016
Location: Highfields
Posts: 10
Posting Frequency
 
Eacth to their own ?
Ghettochilds is offline  
post #15 of 18 Old 10-30-2017, 01:38 PM
GP Rider
 
Capncalyx's Avatar
 
Join Date: Nov 2011
Location: Indianapolis
Posts: 1,921
Posting Frequency
Images: 1
    
Quote:
Originally Posted by Victors View Post
Replace it

*Official winner of one Riflemans 1/5 insert

"Stop being such a Sheila, Peter" - Peter's Dad
Capncalyx is offline  
post #16 of 18 Old 11-01-2017, 11:35 PM
Champion Rider
 
Stealth Rider's Avatar
 
Join Date: Aug 2008
Location: Riverview, FL
Posts: 349
Posting Frequency
Images: 5
  
I had the same issue. I can't find the thread but there was one saying to open up the kickstand switch because sometimes moisture gets in there and somehow causes it to freak out at 8k. The bike thinks the stand is down so it cuts the power. Open up the kickstand switch, clean it up, and see if that works for you. It was the weirdest thing I heard, but it was easy to give it a shot and it worked for me.

"The world is made of two types of people: riders and everyone else. In a country full of lawsuits, threat levels, child proof caps, rules and regulations, owning a motorcycle is one of the last ways to give the middle finger to society's expectation that we constantly be caged and protected. We all want our machines to be a representation of ourselves. Those that ride know being on a motorcycle is not just about getting from point A to B."
John Zamora - Super Streetbike
Stealth Rider is offline  
post #17 of 18 Old 11-03-2017, 12:33 PM Thread Starter
Squid
 
Join Date: Oct 2017
Posts: 5
Posting Frequency
 
Ok update!! Thanks to all first off and I replaced the fuel pump and test drove it yesterday, it seems to be fixed!! Tached on out when I hammered down on it and screamed. . Probably need to have injectors cleaned just by shape of fuel pump pickup sock but all is good , thank everyone for helping me solve this!!!
Jeradcarty is offline  
post #18 of 18 Old 11-03-2017, 03:18 PM
GP Rider
 
Capncalyx's Avatar
 
Join Date: Nov 2011
Location: Indianapolis
Posts: 1,921
Posting Frequency
Images: 1
    


Ive used WitchHunter and ProFlow Technologies for cleaning injectors. Both were great, quick turnaround but ProFlow's overall service was better - even nicely #'ed my injectors by engraving for me since i put them in #'ed bags to begin with. Either way its 100 bucks.
gaz likes this.

*Official winner of one Riflemans 1/5 insert

"Stop being such a Sheila, Peter" - Peter's Dad
Capncalyx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki ZX-10R.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome